Ask Your Question
1

Downgrade a package or Find old rpm files

asked 2016-04-06 09:19:33 -0500

mikechav gravatar image

simply put, I need to install kernel-tools-libs-4.4.5-300.fc23.i686 I have kernel-tools-libs-4.4.6-300.fc23.i686currently. I tried downgrading ( dnf downgrade <packagename> ) but it didn't work. I cannot find a correct rpm file that will install exactly what I need.

I actually need this exact file to undo an install via dnf ( dnf history undo <number>)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
5

answered 2016-04-06 18:07:24 -0500

genodeftest gravatar image

Have a look at https://apps.fedoraproject.org/packages/ , search for a package and click on the "koji" link on the left. You'll find all recent builds for this package there.

edit flag offensive delete link more

Comments

thanks, that worked exactly like I wanted!

mikechav gravatar imagemikechav ( 2016-04-07 10:54:42 -0500 )edit
2

answered 2016-04-06 18:02:07 -0500

sergiomb gravatar image
dnf repoquery | grep kernel

dnf repoquery list all package available , you may grep only kernel packages

dnf list available

list package that you not install and are available

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-06 09:19:33 -0500

Seen: 1,562 times

Last updated: Apr 06 '16