Ask Your Question
0

Problem installing from USB live, goes to black screen

asked 2016-04-28 11:41:21 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hello,

I'm having problems installing from a USB live, I manage to select the option "start Fedora live", but then a screen with only "_" appears from some seconds, and after that black screen.

My computer:

  • Lenovo x1 carbon 4 generation (20FB), Intel i5, Intel(R) HD Graphics 520.
  • Comes with Windows 10 Home 64 Bits
  • BIOS version: N1FET37W (1.11 ). Already latest BIOS.

What I tried:

  • Download Fedora 23 workstations.
  • Create 3 different USB sticks (with dd and Fedora USB live creator)-> same black screen.
  • Disable secure boot BIOS. -> same black screen.
  • When I enabled CSM -> I get a :boot prompt with message "Not a com32r image".

UPDATE: I've trying to mess around with the boot options: https://docs.fedoraproject.org/en-US/...

But I don't think I can, the only prompt I manage to have is the grub promt, and I can edit the "Start Fedora live", one file with "setparams 'Start Fedora live' linuxefi /syslinux....rhgb." I can modify it.

As well tried with Troubleshooting, and Started with the option "Start Fedora Live in basic graphics mode". But same.

edit retag flag offensive close merge delete

Comments

did you try compatible video option to install it ?

aeperezt gravatar imageaeperezt ( 2016-04-28 12:00:44 -0500 )edit

dont know how to try that, do you have a link I can follow?

chusmaellagarto gravatar imagechusmaellagarto ( 2016-04-28 12:05:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-01 00:24:33 -0500

chusmaellagarto gravatar image

Seems there is a kernel bug: https://gist.github.com/lucky/301b559...

They way to make it start temporary is edit the "start fedora live" with the grub options, and add a "intel_pstate=no_hwp" at the end of the efilinux line (the line that starts the kernel).

I have more problems though, seems that my wifi drivers are not included int he kernel 4.2.3. But its included in the 4.5 version.

But when I update to kernel 4.5 in Mint It creates other bug in the screen: https://forums.linuxmint.com/viewtopi...

So when I move the mouse the screen has glitches.

I let it here so it can help others.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-04-28 11:41:21 -0500

Seen: 3,024 times

Last updated: May 01 '16