Ask Your Question

Broadcom is driving me mad

asked 2016-05-05 04:53:26 -0500

Fer gravatar image

Hi guys, first post here. I have a macbook pro 8,2 (early or late 2011, don't currently remember) with a BCM4331. There's no way to get a reliable wifi connection with it. I've tried all Linux drivers: b43, akmod-wl from RPMfusion, and the driver provided by the company in their web page (which is a possibly newer version of the previous one). In general, they connect to the networks at home and at my working place, and everything goes alright until it starts dropping connection and then there's no way to work, to watch videos, or whatever for which you need a reliable connection. I've done my Google job, I've found many posts where people say that some of these solutions work for them like a charm. I've also found fewer, but some posts claiming the same behavior as I'm having, but offering no solutions. Well, some posts suggested specific router configurations I've tried at home to no avail. It was even suggested that this would happen only with specific routers. If only I knew what router should I buy to get a reliable connection at home... I'm with Fedora 23. I'm now with akmod-wl, which works way better than b43. Do you think I would be luckier with older kernels? Have you experienced the same behavior? Do you have a solution or maybe know that there is none?

I would appreciate any kind or help or input. I'm desperate. My wife blames at me for imposing Linux on the family, but my kid is getting older and I don't want her to grow in an environment full of proprietary software! I'll get rid of that MBP as soon as I have money for a new computer, but this may be in at least one or two years...

edit retag flag offensive close merge delete


Welcome to ask.fedora. To answer your feedback question, the moderators here are all volunteers, and check the moderation queue if and when they have the time. Also, as many of them live in the Western Hemisphere, there's going to be more activity here when it's daytime there. Just be patient, and somebody will accept your post as soon as possible. Alas, I'm not familiar with your current issue, but I'm sure that somebody will know how to help you.

sideburns gravatar imagesideburns ( 2016-05-05 13:40:17 -0500 )edit

A further thought. Using the search function brings up a long list of questions about Broadcom. You might want to check some of them and see if there's anything useful. Good luck, and I hope you get this worked out Real Soon Now.

sideburns gravatar imagesideburns ( 2016-05-05 13:44:19 -0500 )edit

@sideburns thanks for clarifying. I thought my message might have got lost because of my connection problems. I looked up broadcom here, but I didn't find anything useful. I'll check again!

Fer gravatar imageFer ( 2016-05-05 15:31:10 -0500 )edit

That's OK, it's often hard to tell if your post made it because the forum software doesn't tell you you're being moderated. Here's a thread from another forum that may help, even though it's a tad old.

sideburns gravatar imagesideburns ( 2016-05-05 17:16:26 -0500 )edit

Have tried using kmod-wl as suggest by @sergiomb in his answer below?

florian gravatar imageflorian ( 2016-05-05 21:55:56 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2016-05-05 19:35:00 -0500

sergiomb gravatar image

updated 2016-05-05 22:34:29 -0500

Attention on F23 you need enable update testing:

latest version is wl-kmod-

yes, btw is akmod-wl [1] , because RPM Fusion don't have pre-built kmods for F22 and F23 ( yet ) , should be installed along with kernel-devel

dnf install akmod-wl kernel-devel-$(uname -r)


edit flag offensive delete link more


Thanks, but yes, I have the latest version of both packages (also of the kernel, of course), and I've checked with previous versions of everything, unfortunately with very similar outcomes. I've also checked with other distros, but not with olden ones. That's why I wonder if I would be more successful with an old kernel (thinking of Debian, Centos...). I've also played a little bit with the router configuration, but not with the driver configuration. Any idea in this direction would be very much appreciated.

Fer gravatar imageFer ( 2016-05-06 01:30:14 -0500 )edit

if you use akmod-wl from RPMFusion you may (or should) open a bug report on

sergiomb gravatar imagesergiomb ( 2016-05-06 15:57:45 -0500 )edit
Fer gravatar imageFer ( 2016-05-07 02:50:16 -0500 )edit

answered 2016-05-08 02:46:11 -0500

ldlyu gravatar image

I use macbook pro mid 14, and I use an older kernel (4.2.3-300) and kmod-wl-4.2.3-300.fc23 to make the wifi work. So yes, an older kernel may be a solution.

edit flag offensive delete link more



@ldlyu thanks for answering! It doesn't make any difference in my case. I'm starting to think that I have a hardware problem. Do you happen to have this configuration because you had breakage with kernel upgrades? Or it is just what you started with?

Fer gravatar imageFer ( 2016-05-09 04:59:43 -0500 )edit

The reason is pragmatic. There is a kmod-wl for 4.2.3-300 but not for 4.4.8-300 -- the other kernel installed.

ldlyu gravatar imageldlyu ( 2016-05-10 01:36:43 -0500 )edit

@ldlyu in order to get the driver installed in 4.4.8 and in all future kernels without further action on your side, you can install akmod-wl. It ends up installing exactly the same version of the driver that kmod-wl provides for kernel 4.2.3.

Fer gravatar imageFer ( 2016-05-10 06:06:42 -0500 )edit

Thank you!

ldlyu gravatar imageldlyu ( 2016-05-12 06:52:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2016-05-05 04:53:26 -0500

Seen: 635 times

Last updated: May 05 '16