English
Ask Your Question
9

[Sticky] How do I install Skype on Fedora?

asked 2013-01-16 00:11:38 +0000

Natherul gravatar image

updated 2017-01-13 21:03:38 +0000

mattdm gravatar image

How do I install Skype on Fedora?

edit retag flag offensive close merge delete

Comments

And how about use lpf-skype ? https://ask.fedoraproject.org/en/ques...

sergiomb ( 2015-05-21 14:36:28 +0000 )edit

Well, for third party applications that already provide fedora repositories and packages, I don't see a point of using lpf which will just download, rebuild and then redeploy them (if i understand the functioning of lpf properly). Why shouldn't a user just use the provided package instead of using a tool which fetches this package and rebuilds it?

FranciscoD_ ( 2015-05-21 19:10:56 +0000 )edit

Hi, lpf could be better because install all dependencies, package could have some improvements, provides updates and we will have more uniform tests .

sergiomb ( 2015-05-23 16:51:13 +0000 )edit

How exactly does lpf work? Skype doesn't provide source, so you're pretty much just extracting the rpm they provide and repackaging it, right? What tests can you run on that? Doesnt the user need to have packaging utils installed for lpf to work - I assume lpf would pull these things in?

FranciscoD_ ( 2015-05-29 13:00:11 +0000 )edit
1

Is a piece of art :) , download the static tar.gz and put it in an rpm , may ask user to approve the restrict license and is the user that download the content, so lpf could deal with non-redistribution code , like skype. yeah lpf is for generic software, skype have rpms , but others can't have , also we could improve installation of desktop integration etc and of course deal with all dependencies.

sergiomb ( 2015-05-29 13:13:05 +0000 )edit

11 answers

Sort by ยป oldest newest most voted
11

answered 2013-01-17 19:04:50 +0000

Akshay gravatar image

updated 2016-07-26 17:33:36 +0000

Open a terminal

64 bits

su
dnf -y install https://repo.skype.com/latest/skypeforlinux-64-alpha.rpm

OLD VERSION

32 bits

Download the skype RPM from the official website and select Fedora 32 bit (or simply click here)

You can then simply double click on the package and packagekit should offer to install it for you. If you'd like to use the terminal, use:

sudo yum localinstall skype-*.rpm

64 bits

If you are using a 64 bit system(x86_64), then you need to manually install some of these packaages

sudo yum -y install libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686 pulseaudio-libs.i686 pulseaudio-libs-glib2.i686 alsa-plugins-pulseaudio.i686

NOTE: For Fedora 22+, please replace yum with dnf.

Screenshot of Skype running on Fedora 18

image description

@FranciscoD_ Thanks for the Correction...

edit flag offensive delete link more

Comments

1

If using skype on a 64bit system, one might need to manually install some 32bit packages as detailed here: http://fedorasolved.org/Members/dcr226/installing-skype

Can you please update your answer to include this information @Akshay? Thanks.

FranciscoD_ ( 2013-08-24 02:07:58 +0000 )edit
1

By the way you do not need to write yum localinstall if you want to install a rpm package from a local file. You can just write yum install. The man page says for localinstall: This command is maintained for legacy reasons only.

erik ( 2013-09-20 08:35:59 +0000 )edit
2

As an additional note @Akshay in Fedora 22 you don't need localinstall, just type dnf rpm_file_name.rpm and dnf will gather the required packages to install. Sorry I can't update the answer cause I don't have enough Karma

Juan Alpizar ( 2015-08-03 14:53:44 +0000 )edit

The link provided by @FranciscoD_ no longer works and I have been trying to follow the steps in all the answer without any luck

mauriciograciag ( 2015-08-04 02:31:11 +0000 )edit
1

The link in the comment is no longer needed. He edited the answer to include all that information.

FranciscoD_ ( 2015-08-04 11:14:03 +0000 )edit
2

answered 2016-01-31 17:24:36 +0000

Ervin-Reloaded gravatar image

In 23 dependencies are sorted automatically. All you need to do is download the Skype package for Fedora and double click to install it.

edit flag offensive delete link more

Comments

That's for sure

droppop ( 2016-02-13 11:09:21 +0000 )edit

For Fedora 22 and 24 this also works. Just install the Fedora 32 bit package. The dependencies will automagically be resolved. Though I had to do it via command line: dnf install skype-4.3.0.37-fedora.i586.rpm (see answer on http://superuser.com/a/1021665/180675 )

erik ( 2016-03-17 19:09:24 +0000 )edit
1

answered 2016-06-08 23:07:02 +0000

Saritasa gravatar image
dnf config-manager --add-repo=http://negativo17.org/repos/fedora-skype.repo
dnf -y install skype
dnf -y install skype4pidgin

taken from here: http://negativo17.org/skype-and-skype...

edit flag offensive delete link more
1

answered 2017-03-13 19:54:15 +0000

hhlp gravatar image

updated 2017-03-13 19:54:54 +0000

Now skype support rpm packages and 64 bits native not need to install 32 bits depenencies.

download from here

open a terminal and instal it

sudo dnf install skypeforlinux-64.rpm

Regards.,

edit flag offensive delete link more
1

answered 2016-07-27 19:14:16 +0000

florian gravatar image

updated 2016-07-27 19:19:22 +0000

For Fedora 23+ 64-bit systems, download and install Skype from the stable branch using dnf:

sudo dnf config-manager --add-repo https://repo.skype.com/data/skype-stable.repo 
sudo dnf install skypeforlinux

The "new" Skype, based on WebRTC, which is still in alpha phase, can be found here: https://repo.skype.com/latest/

(no video chat yet, ...)

edit flag offensive delete link more
1

answered 2017-03-13 21:12:23 +0000

florian gravatar image

updated 2017-03-14 10:55:01 +0000

hhlp gravatar image

I would use flatpak to install/run Skype : http://flatpak.org/apps.html

or use the command line :

flatpak install --from https://s3.amazonaws.com/alexlarsson/skype-repo/skype.flatpakref
flatpak run com.skype.Client
edit flag offensive delete link more
-1

answered 2016-01-19 16:19:14 +0000

Try the negativo Skype repository. It has generally always worked very well, and has support for Fedora 21+ and CentOS/RHEL 6 and 7.

http://negativo17.org/skype-and-skype...

edit flag offensive delete link more
-1

answered 2013-01-16 04:25:11 +0000

Hex_K gravatar image

Try:

yum install qtwebkit.i686

there might be other dependencies that must be installed as well.

edit flag offensive delete link more

Comments

Hi all, I am trying to get Skype installed on Fedora 18 64 bits OS. I am following the instructions on the next link: http://www.if-not-true-then-false.com/2012/install-skype-on-fedora-centos-red-hat-rhel-scientific-linux-sl/ I am getting the following error(similar to the first one poster, but it has nothing to do with duplicate versions) while trying to install the first dependencies: Protected multilib versions: freetype-2.4.10-4.fc18.i686 != freetype-2.4.10-3.fc18.x8664 Error: Protected multilib versions: 1:qt-4.8.4-17.fc18.i686 != 1:qt-4.8.4-14.fc18.x8664 Thanks!:-)

rodionrom ( 2013-06-02 14:29:49 +0000 )edit

Not required any more.

genodeftest ( 2016-04-12 19:20:51 +0000 )edit
-1

answered 2013-01-16 19:14:47 +0000

Hex_K gravatar image

You could try

yum install libXScrnSaver.i586

also check out this page

http://www.if-not-true-then-false.com/2012/install-skype-on-fedora-centos-red-hat-rhel-scientific-linux-sl/

edit flag offensive delete link more

Comments

1

That didn't work for me. The dependecies on my 64 F20 cannot be installed.

theking2 ( 2014-02-02 13:31:51 +0000 )edit

Not required any more.

genodeftest ( 2016-04-12 19:21:09 +0000 )edit
-3

answered 2016-01-30 20:21:59 +0000

valentt gravatar image

I use Fedy to install Flash plugin and to do other post-install Fedora tweaks. Highly recommended.

edit flag offensive delete link more

Comments

Does it work on 23?

Ervin-Reloaded ( 2016-01-31 17:23:31 +0000 )edit

Yes it works on Fedora 23.

valentt ( 2016-01-31 21:24:20 +0000 )edit
2

But please read this before installing and using Fedy: https://ask.fedoraproject.org/en/ques...

florian ( 2016-02-01 19:16:42 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2013-01-16 00:11:38 +0000

Seen: 89,823 times

Last updated: Mar 14