Ask Your Question
0

hi I have a problem which is (Failed to set locale, defaulting to C )

asked 2016-05-11 09:10:01 -0500

AbDo gravatar image

It's happened when I install via the terminal, for example

 dnf config-manager --add-repo=http://negativo17.org/repos/fedora-steam.repo

Failed to set locale, defaulting to C Adding repo from: http://negativo17.org/repos/fedora-st... or

yum reinstall glibc-common

Yum command has been deprecated, redirecting to '/usr/bin/dnf reinstall glibc-common'. See 'man dnf' and 'man yum2dnf' for more information. To transfer transaction metadata from yum to DNF, run: 'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'

Failed to set locale, defaulting to C Last metadata expiration check: 0:46:47 ago on Wed May 11 16:18:58 2016.

Dependencies resolved.

Package Arch Version Repository Size

Reinstalling: glibc-common x86_64 2.22-15.fc23 updates 12 M

Transaction Summary

Total download size: 12 M

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-11 15:46:25 -0500

genodeftest gravatar image

yum is deprecated (as your output above says). So any howtos/guides recommending to use yum are old and should be updated. Until they are, please ignore them.

What does dnf reinstall glibc-common return?

You probably should run dnf langlist. If it doesn't give you any installed language, follow these steps: 1. run dnf langavailable and find your language from this list. Note the 2- or 3-letter language code in square brackets. 2. run dnf langinstall xx with xx replaced by your language code. 3. if glibc-langpack-xx still isn't installed, install it manually. That's a bug and I've reported it at Bugzilla.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-05-11 09:10:01 -0500

Seen: 3,219 times

Last updated: May 11 '16