English
Ask Your Question
1

gnome-shell; High CPU Usage [closed]

asked 2012-10-25 04:27:07 +0000

Chandies gravatar image

updated 2015-06-02 08:25:09 +0000

This weekend I migrated to a new laptop, an Acer Aspire V3-551-8887 (4gb RAM, AMD A8-4500m quad core). With a new laptop, I thought I'd make the jump to Fedora 17 (F16 was on my previous laptop).

All worked well after the DVD install and applying all pending updates, but I notice that both Top and System Monitor show abnormally high CPU usage, 100 - 150%, or more.

The process is tagged as gnome-shell, but I am not very experienced at looking u'under-the-hood' in linux to get further information.

Any ideas? I'm sure there's more information I can give you, I just don't what would be needed or how to obtain it, yet.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by florian
close date 2017-07-07 13:24:12.779629

4 answers

Sort by » oldest newest most voted
0

answered 2017-07-07 12:02:39 +0000

noblesw gravatar image

I realize that this post is old, but I am having the same problem using Fedora 25 Server. I installed the gnome-tweak-tool, but under Extensions, I have no extension labeled Background Logo. Brand new box, but it is acting like it's 30 years old because CPU usage is at 98%

edit flag offensive delete link more

Comments

Please open a new question.

florian ( 2017-07-07 13:23:46 +0000 )edit
0

answered 2016-02-03 05:30:00 +0000

bodi gravatar image

My laptop (Fedora 23) had a similar problem, but I realised that it only appeared when connected to a secondary screen. The solution was via “Settings” → “Displays” → “Arrange Combined Displays” to readjust the relative positioning of the screen areas.

edit flag offensive delete link more
1

answered 2015-03-25 17:19:47 +0000

Joris gravatar image

I've had this problem as well. My solution was to disable the extention "Background Logo", which draws the fedora logo on top of your background.

My CPU usage is back to 2% right now.

To disable the extention: Install gnome-tweak-tool

sudo yum install gnome-tweak-tool

Start the tweak tool and disable the extention "Background Logo" in the overview "Extentions"

edit flag offensive delete link more

Comments

This did it for me! Thanks so much. And it's not even removable via the panel, so I could only disable it. Weak.

Daniel Quinn ( 2015-04-09 10:25:25 +0000 )edit
1

answered 2013-03-02 09:44:36 +0000

Bucic gravatar image

You should re-check it with system freshly booted and no additional programs fired up to make sure Gnome Shell isn't forced to do some heavy redrawing on some windows (e.g. few opened video players). If the situation still persists you should submit a bug report
https://bugzilla.gnome.org/
and/or
https://bugzilla.redhat.com/

Make sure to go through the following article first
https://fedoraproject.org/wiki/Bugsandfeature_requests

edit flag offensive delete link more

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2012-10-25 04:27:07 +0000

Seen: 9,954 times

Last updated: Jul 07