Ask Your Question
0

Fedora 18 ibus broken

asked 2013-01-17 15:17:38 -0600

kimbn gravatar image

updated 2013-06-10 20:10:24 -0600

mether gravatar image

After installing Fedora 18 Gnome Desktop, I tried to use ibus and ibus-hangul for Korean.

I ran im-chooser and select ibus, but I got a following error pop-up :

"Failed to switch input Method"

"GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.Code5: 
    Current desktop isn't targeted by Input Method."

I clicked "Log Out" and logged in again, but ibus didn't work at all. I could not toggle between English and Korean.

By the way, Fodora 17 had no problem with ibus and ibus-hangul. Something quite broke in ibus in Fedora 18.

edit retag flag offensive close merge delete

Comments

Same problems, same error messages which I did not have with Fedora 16, my previous version.

stratus17 gravatar imagestratus17 ( 2013-01-19 12:15:49 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-20 07:48:06 -0600

kimbn gravatar image

Well, I've learned that Gnome 3.6 does not support external ibus. It has integrated ibus.

In the Region & Language setting I've added Korean(Hangul) input source, and assigned Ctrl+Space to the next input source switching shortcut, I can now switch between Korean and English.

By the way, the switching response is very slow; it takes at least a half second.

edit flag offensive delete link more
0

answered 2018-12-05 10:22:05 -0600

simmon gravatar image

Hangul Problem.. in Fedora System. I Can Support ....for Korean Users... written by simmon

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-01-17 15:17:38 -0600

Seen: 4,045 times

Last updated: Dec 05