Ask Your Question
1

Can't install base-x group with dnf [closed]

asked 2016-05-25 10:47:46 -0500

marmarek gravatar image

When trying to install base-x I get this error:

[user@work ~]$ sudo dnf group install base-x
Last metadata expiration check: 1:14:17 ago on Wed May 25 10:20:49 2016.
No package xorg-x11-drv-modesetting available.
Error: Unable to find a mandatory group package.

But xorg-x11-drv-modesetting is provided by xorg-x11-server-Xorg:

[user@work ~]$ sudo dnf whatprovides xorg-x11-drv-modesetting
Last metadata expiration check: 1:17:55 ago on Wed May 25 10:20:49 2016.
xorg-x11-server-Xorg-1.18.3-2.fc23.x86_64 : Xorg X server
Repo        : @System

xorg-x11-server-Xorg-1.18.3-2.fc23.x86_64 : Xorg X server
Repo        : updates

xorg-x11-server-Xorg-1.18.0-0.4.20150907.fc23.x86_64 : Xorg X server
Repo        : fedora

If I exclude xorg-x11-drv-modesetting, it complains about another package, xorg-x11-drv-geode

[user@work ~]$ sudo dnf group install base-x --exclude xorg-x11-drv-modesetting
Last metadata expiration check: 1:19:32 ago on Wed May 25 10:20:49 2016.
No package xorg-x11-drv-geode available.
Error: Unable to find a mandatory group package.

Which indeed isn't available. There are also other packages in base-x group which aren't available, for example xorg-x11-drv-armsoc.

I've got here trying to upgrade Fedora Workstation group, which ended up with much less descriptive error:

[user@work template_scripts]$ sudo dnf group upgrade 'Fedora Workstation'
Last metadata expiration check: 0:10:37 ago on Wed May 25 04:53:19 2016.
Error: xorg-x11-drv-modesetting

Am I doing something wrong, or is it a bug? I've somehow managed to install the system, so I guess it my fault...

PS The same with yum-deprecated works just fine.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by hhlp
close date 2016-05-28 05:22:14.407906

Comments

Hi, I also met the same trouble when I newly installed "Fedora Workstation" group on Fedora 23 server. It seemed to happen around xorg-x11-drv-* and polkit-js-engine. So now I can not install them with dnf. How can I manage it?

Sio gravatar imageSio ( 2016-05-25 23:31:53 -0500 )edit

Same problem here, I don't understand... I upgrade my system from 19 to 23, and now I have no idea why, I can't install anything related to a desktop environnement, because I have always a "xorg" package missing, and theses xorg package doesn't existe on F23...

Seriously, I don't understand...

funkybear gravatar imagefunkybear ( 2016-05-26 17:01:04 -0500 )edit

There is an open bug here : https://bugzilla.redhat.com//show_bug...

aoroni gravatar imageaoroni ( 2016-05-27 09:37:49 -0500 )edit
hhlp gravatar imagehhlp ( 2016-05-28 05:22:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-27 10:00:30 -0500

florian gravatar image

Have you seen this Q/A ?.

Seems to be a bug in dnf that already was reported here

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2016-05-25 10:47:46 -0500

Seen: 1,849 times

Last updated: May 27 '16