English
Ask Your Question
3

How can I change default Operating System in start up boot menu?

asked 2012-06-16 10:44:25 +0000

sabi gravatar image

updated 2012-06-16 10:47:25 +0000

How can I change default Operating System in start up boot menu? It is Fedora 17 now and I want to set it on Win 7.

edit retag flag offensive close merge delete

Comments

you should read this -> http://ask.fedoraproject.org/question/526/dual-boot-fedora-16-windows

hhlp ( 2012-06-16 16:28:41 +0000 )edit

Unfortunatly it did not work for me, after i've gone through the process of setting windows 7 to a default, after doing these commands, my fedora crashed and i couln't login onto desktop anymore :(. I get sendmain starting, hangs there and that's it, no splash sreen shows up, nothing! Any one can tell, if there is another way to fix the boot order, like a graphical interface? Thanks!

xcomb ( 2013-11-05 06:20:06 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
6

answered 2012-06-18 14:36:07 +0000

Akshay gravatar image

updated 2012-06-18 14:37:07 +0000

In a terminal type:

grep menuentry /boot/grub2/grub.cfg

This will display all your grub entries

Highlight the entry you want to default to - for example Windows 7 (loader) (on /dev/sda1) Right click and choose copy

Type

gedit /etc/default/grub

Change the entry

GRUB_DEFAULT=0

to

GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda1)"

i.e. paste the entry you want (including the quotes)

Save, then type

grub2-mkconfig -o /boot/grub2/grub.cfg
edit flag offensive delete link more

Comments

Seems like you are trying to run gedit as root. For gedit to work this way, use "gedit -s /etc/default/grub"

This disables the dbus check so it can be used as root.

LooseWire29710 ( 2012-12-28 22:26:09 +0000 )edit

when i try to save by command grub2-mkconfig -o /boot/grub2/grub.cfg.....i am getting no such file found.

Ajay ( 2013-03-01 03:50:11 +0000 )edit

'gedit' isn't really the ideal command to be editing files as root, even if you can disable the dbus interface. Try a simple editor like nano, which has on-screen instructions.

wquine ( 2013-08-07 01:38:01 +0000 )edit

Maybe you had add an extra space after the plus sign, just delete it and everything works fine.

salah ( 2014-07-11 18:31:35 +0000 )edit
0

answered 2013-08-07 01:19:16 +0000

First Move to SuperUser

su

Then search the grub menu entries of your grub

grep menuentry /boot/grub2/grub.cfg

Now edit the grub config by an editor

vi /etc/default/grub

Change the timeout and the GRUB_DEFAULT=0 to GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda1)" The "Windows 7 (loader) (on /dev/sda1)" thing is for Windows 7. You can find your text from the grep menuentry /boot/grub2/grub.cfg

Now save and close form text editor and type the command

grub2-mkconfig -o /boot/grub2/grub.cfg

You are all Done!!

edit flag offensive delete link more

Comments

Other than the timeout, how does this differ from the existing answer? Why change the timeout, anyway?

randomuser ( 2013-08-07 02:20:08 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
2 followers

Stats

Asked: 2012-06-16 10:44:25 +0000

Seen: 81,308 times

Last updated: Nov 05 '13