Ask Your Question
0

how to disable SendEnv variables set in ssh_config from ~/.ssh/config

asked 2012-10-09 13:50:09 -0600

Aleksandar Kostadinov gravatar image

updated 2014-09-29 00:28:55 -0600

mether gravatar image

I couldn't find that anywhere so I'm wondering am I the only one hitting such issue.

By default ssh has a sshconfig with SendEnv option passing LC* and LANG variables in the remote session. If one is not root to change /etc/ssh/sshconfig, how can he disable that behavior? SendEnv option seems to be accumulating and I can't see any way to reset it.

And to avoid being asked, I need to avoid passing locale to test machines to avoid side effects on scripts and programs that rely on locale being the default for the machine.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-10-15 09:10:53 -0600

Aleksandar Kostadinov gravatar image

To answer my own question, one currently just can't.. except for providing an alternative global configuration file on command line with "-F".

https://bugzilla.mindrot.org/show_bug.cgi?id=1285

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-09 13:50:09 -0600

Seen: 2,672 times

Last updated: Oct 15 '12