English
Ask Your Question
1

Cannot install Fedora 24

asked 2016-06-24 10:39:15 +0000

deajan gravatar image

Hello,

I've already submitted this to bugzilla ( https://bugzilla.redhat.com/show_bug.... ). When I start the F24 install media (verified with sha256sum), I end up with the following:

[ OK ] Starting Location Lookup Service...[ OK ] Started Location Lookup Service.[ OK ] Started session c6 of user gdm.

(These messages are shown 6 times, for user c1 to c6).

When going to TTY2, dmesg gives:

20.196734 do_trap: 12 callbacks suppressed 20.197634 traps: gnome-shell[1887] trap invalid opcode ip:7f78d1a2608f sp:7ffd180df8c0 error:0

Another 10 of these traps messages are present.

I've tried to boot with nomodeset, disabling CSTATES because of previous skylake problems I ran into. I cannot use the text installer because of the limited partitionning possibilites. The same thing already happened with F24 beta install media.

Any thoughts of what I could do ?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2016-06-29 07:43:15 +0000

deajan gravatar image

Finally got it sorted out, it was the Nvidia GM107M (GT960M) that made gnome-shell fail. Adding "rd.blacklist.nouveau=0" to the kernel boot cmdline does not blacklist nouveau anymore (lsmod still shows the driver loaded). Had to use "nouveau.modeset=0" in order to get things sorted out.

edit flag offensive delete link more

Comments

Thanks!!! but, How can I do that??? I am new whit GNU/Linux and I have the same problem, cant run the installer. Please. Thanks. (sorry for my bad english).

alankepler ( 2016-07-13 21:18:30 +0000 )edit
1

answered 2016-06-24 19:40:55 +0000

genodeftest gravatar image

Have you run Fedora 23 with wayland before? If no, then try this:

  1. Ctrl+Alt+F3, log in as root
  2. in /etc/gdm/custom.conf, uncomment #WaylandEnable=false and save the file.
  3. restart gdm or reboot

If you have run Fedora 23 with wayland before, try get to the syslog:

  1. Ctrl+Alt+F3, log in as root
  2. run journalctl -b and go to the end

If that doesn't help, try this:

  1. In /etc/systemd/journald.conf uncomment this line: TTYPath=/dev/tty12 or add it to the file.
  2. Reboot.
  3. Ctrl+Alt+F12 to see syslog. It should give you some useful info.
edit flag offensive delete link more

Comments

I don't see the point of trying to run F23 with wayland as F24 still ships with X.org by default. Any particular reasons ? Here's the output of jounalctl -b when booted with F24 install media (which also uses X.org as of my understanding): https://gist.github.com/deajan/cbc505...

deajan ( 2016-06-27 07:45:14 +0000 )edit

GDM, the display manager that handles login, does run in Wayland by default. The suggestion is to disable wayland.

randomuser ( 2016-06-28 00:37:07 +0000 )edit

Well, sorry but F24 install media still uses X.org, there isn't even a WaylandEnable directive in /etc/gdm/custom.conf

deajan ( 2016-06-29 07:42:32 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
3 followers

Stats

Asked: 2016-06-24 10:39:15 +0000

Seen: 1,012 times

Last updated: Jun 29 '16