English
Ask Your Question
1

texstudio only runs as root on Fedora 24

asked 2016-06-27 08:53:33 +0000

nathan.huesken gravatar image

updated 2016-07-30 15:56:27 +0000

Hey,

After installing fedora 24 I want to start textstudio. Unfortantly, it works only with

sudo texstudio

Trying to start it as a normal user gives me:

texstudio 

(texstudio:19207): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'

(texstudio:19207): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(texstudio:19207): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(texstudio:19207): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(texstudio:19207): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(texstudio:19207): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(texstudio:19207): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(texstudio:19207): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'

(texstudio:19207): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(texstudio:19207): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(texstudio:19207): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(texstudio:19207): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

And then nothing happens.

Ideas? Thanks!

edit retag flag offensive close merge delete

Comments

I can confirm that you are not crazy, and that this issue is reproducible by installing Fedora 24, fully updating it, and then installing texstudio. Running it as a non-root user fails in the way you describe, and running it with sudo (or as root) works. I'm investigating, but I thought I'd post this for anyone out there who might want to reproduce this issue in a VM and try to resolve it as well.

bitwiseoperator ( 2016-07-30 15:55:37 +0000 )edit

Could anyone perhaps try to test installing qt5-qtstyleplugins and additionally test if the following command works. It would be great if anyone could check if this is installed in a newly created fedora 24 (Gnome).

 QT_STYLE_OVERRIDE=gtk2 texstudio
hannes ( 2016-08-25 08:08:37 +0000 )edit

9 answers

Sort by ยป oldest newest most voted
0

answered 2016-07-30 07:08:55 +0000

hannes gravatar image

updated 2016-08-01 07:48:04 +0000

Could you perhaps try to change the texstudio style? It seems that the Gtk+ style is failing and perhaps it's working when using another one like "Fusion" or "default". I think it should be possible by editing

~/.config/texstudio/texstudio.ini Please look for the line X11\Style=GTK+ and change it to X11\Style=default. Hope this helps

edit flag offensive delete link more

Comments

YES! Thats it! Thank you very much!

eddie8 ( 2016-08-10 14:59:18 +0000 )edit

Thank you! This worked for me

blazek ( 2016-11-12 19:17:50 +0000 )edit

I have no such file as textstudio.ini in ~/.config/texstudio/

jaaf64 ( 2016-11-13 09:02:55 +0000 )edit
0

answered 2016-10-26 17:48:06 +0000

Perfect! It's working. Thanks....

edit flag offensive delete link more
0

answered 2016-09-29 16:26:49 +0000

rommon gravatar image

This may help

dnf remove qgnomeplatform

as expressed in: https://ask.fedoraproject.org/en/ques...

edit flag offensive delete link more
0

answered 2016-09-13 23:41:25 +0000

same problem here, yet.

edit flag offensive delete link more
0

answered 2016-09-06 21:34:54 +0000

Dr. J gravatar image

Working with a fresh install of Fedora 24 so had no existing working install to copy.

Initially tried to run as root and copy the .config/texstudio to my own .config/ directory, then change the owner and group. That didn't work.

I then ran it as root, changed the window manager to (default - i think, or something other than gtk+) then went though the same process. This seems to have worked, however, I did fiddle with other things in between (on of which might have worked). Could someone test?

edit flag offensive delete link more
0

answered 2016-07-31 14:45:34 +0000

hannes gravatar image

Did you try to change the style of the GUI as I've described in https://ask.fedoraproject.org/en/ques...

edit flag offensive delete link more
0

answered 2016-06-27 22:00:20 +0000

ssnow gravatar image

I've been running TeXstudio on Fedora since F17. I cannot seem to replicate your particular problem, and I only run it as a normal user without using sudo. Did you upgrade to F24 from F23? If so, did you change your display manager? Are you using Gnome with X or with Wayland?

(edit) OK, so I tried with Gnome on Wayland and I still cannot replicate your problem.

edit flag offensive delete link more

Comments

I made a fresh f24 install. I have this problem on 3 independent computers. Mmmh, of course all the setups are similar, but still ... I am not using wayland.

nathan.huesken ( 2016-06-28 08:11:44 +0000 )edit

Perhaps it is a problem with QT on your new install. TeXstudio uses the QT libraries I believe, and the errors you have above would seem to be relevant to those libraries.

ssnow ( 2016-06-28 14:42:54 +0000 )edit

Did some checking around TeXstudio support forums, and it seems there are some known issues with QT/Unity (QT 5.51 and 5.54 I believe specifically). Perhaps a downgrade of QT is in order.

ssnow ( 2016-06-28 14:51:03 +0000 )edit
0

answered 2016-07-20 03:15:32 +0000

I had the same problem, delete the texstudio folder inside the ~/.config folder, download the texstudio Linux AppImage, start the texstudio Linux AppImage, close it and try again with normal user. This worked for me.

edit flag offensive delete link more
0

answered 2016-07-11 07:14:33 +0000

eddie8 gravatar image

updated 2016-07-11 08:26:36 +0000

Same problem here. During the beta-time of F24 texstudio worked fine. Since about the released version I have the same failure mentioned above.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2016-06-27 08:53:33 +0000

Seen: 1,360 times

Last updated: Sep 29 '16