Ask Your Question
0

How can I get vncserver to use XFCE?

asked 2011-11-15 04:10:46 -0500

Although GNOME 3 is great for a desktop environment when sat at the console, it performs extremely poorly over the network. How can I use a different graphical environment for VNC?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-11-15 04:14:50 -0500

updated 2011-11-16 05:17:41 -0500

After starting vncserver the first time, you will have a ~/.vnc/xstartup file which contains the instructions for starting the session. It tries to run the same session you would get if you logged in locally.

Edit that file so that it contains this instead (for XFCE):

#!/bin/sh
exec /bin/sh /etc/xdg/xfce4/xinitrc

Make sure the xfce-utils package is installed. Now when you start the VNC server you'll get an XFCE session, which is much better over network connections.

edit flag offensive delete link more

Comments

You should have to allow incoming connection in the firewall

sudo firewall-cmd --zone=public --add-port=5901/tcp
alcir gravatar imagealcir ( 2017-05-30 06:51:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-15 04:10:46 -0500

Seen: 21,255 times

Last updated: Nov 16 '11