Ask Your Question
1

Kernel 4.6.* won't boot

asked 2016-07-21 01:37:16 -0600

TLMiller gravatar image

Updated my F23 to F24, everything went fine until the 4.6.3 kernel was released. After installing, my machine wouldn't boot. No splash, no nothing as soon as Grub passed control to init. All prior kernels still work fine. I read someone else that had the same issue, but a reinstall fixed, so I tried a reinstall today after the 4.6.4 kernel has the same issue as the 4.6.3.

After reinstall, no change. The default 4.5.5 kernel has absolutely no issues, 4.6.4 stops responding as soon as it begins to boot.

I don't see anything in /var/log/messages that would seem relevant.

My machine is:

Asrock 970 Extreme3 motherboard AMD FX 8320 cpu 16 GB ram 960 GB SSD 4 GB GTX 970 gpu (using nouveau without issue on 4.5.5) 5.1 pci sound card (onboard sound died years ago)

Anyone have any ideas of how to get my machine booting with 4.6.*?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2016-07-21 04:26:39 -0600

rdtcustomercare gravatar image

THIS IS NOT THE ANSWERE TO THAT PROBLEM, IT'S a general approach to solve the problem.

check this http://marius.bloggt-in-braunschweig.... german Link for a guide, how to get into rootconsole for your actual kernel .

basically:

  1. get into grub menu
  2. select kernel
  3. press "e"
  4. edit LINUX line by ADDING a " 1" to the end REMOVE the keywords "rhgb quiet splash"
  5. Press F10 to boot into Emergency boot

IF that works, your kernel is fine and 10:1 some kernel mods are missing.

Login as root enter "akmods" to build missing modules, that should have been build automatically IF you DO NOT HAVE any moduls to build, kernel-modules could be missing at all

Check if you have the RPMs kernel-NUMBER-modules and kernel-NUMBER-modules-extras installed:

rpm -qa | grep kernel | sort

IF NOT, install them with DNF :

dnf install kernel-NUMBER-modules ....

reboot

I hope this has been of any usage to you. Cu.

edit flag offensive delete link more

Comments

Nope, no change other than I can see a second or 2 of messages before it stops booting.

TLMiller gravatar imageTLMiller ( 2016-07-21 09:26:59 -0600 )edit
0

answered 2016-07-21 03:38:00 -0600

Cenz gravatar image

I'm having a similar issue on my Dell Latitude E7470 Intel I7. Besides, cracking my head on a nearby wall, I've figured that 4.6.* has issues detecting cpu core >1. To get around this I've added maxcpus=1 to the kernel parameters in the grub.conf You can temporary test it by pressing "e" on kernel name on the grub menu and then adding that.

I've managed to boot successfully using this workaround.

edit flag offensive delete link more

Comments

Nope, this doens't work either. Still fails to boot almost immediately.

TLMiller gravatar imageTLMiller ( 2016-07-21 09:27:25 -0600 )edit
0

answered 2016-07-24 12:26:37 -0600

Good day! I to was having this problem but it turned out to be a kernel module issue for me. After upgrading to the newest kernel in the stable repo when I would boot into the new kernel mine would stick as well. How I fixed it was by installing the kernel-devel package so that it could recompile the modules needed by the kernel since I believe the modules are no longer good for that version. To install the kernel-devel package run the following command.

sudo dnf install kernel-devel

That will get you the latest devel package for the kernel. Now for a specific version run the command after changing the version to the version you are trying to install.

sudo dnf install kernel-devel-<version of kernel> #EX: kernel-devel-4.6.4-301.fc24.x86_64

This is what fixed my problem. I hope it works for you as well.

edit flag offensive delete link more

Comments

:( 4.6 hates my machine. This also had no change.

TLMiller gravatar imageTLMiller ( 2016-07-25 11:38:57 -0600 )edit
0

answered 2016-08-14 14:11:02 -0600

Kannan gravatar image

Are you using nvidia graphics card? I had the same issue with an nvidia graphics card. If you are able to boot in to safe mode you can check your previous boot log with the following command

journalctl --boot=-1

If you see any errors with the nouveau driver then adding the following to the linux/linuxefi line might help.

nouveau.modeset=0

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-07-21 01:30:40 -0600

Seen: 1,209 times

Last updated: Jul 21 '16