Ask Your Question
1

Can't Tethering - Which Component is Responsible for Tethering?

asked 2016-07-28 01:16:35 -0600

akun gravatar image

updated 2016-07-30 05:21:46 -0600

Excuse me,

I am new to Fedora and I think it is a good Linux distribution. Thank you very much for Fedora Project team.

I experienced wireless networking problem. As far as I remember, I didn't experienced this in Fedora 22 or older. I think it is somewhere in version 23, after certain update. This problem continues until version 24.

I can not use mobile hotspot (internet sharing connection / tethering) with Windows Phone Lumia 435. Has anybody experienced the same problem using other smartphones (Android / iOS)? I found no problem using the same laptop with Windows 10 (dual boot). (Laptop: Lenovo z480)

I tried to report this on Redhat bugzilla system. When I open "enter_bug.cgi" page, there is a required "Component" field. I don't know which component is responsible for tethering. Which component handles tethering in Fedora?

My apology, I'm not good at English, I wish my question could be easily understood.

Thank you very much.


some of journalctl output

Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.2650] device (wlp4s0b1): disconnecting for new activation request.
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.2652] device (wlp4s0b1): state change: activated -> deactivating (reason 'new-activation') [100 110 60]
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.2653] manager: NetworkManager state is now DISCONNECTING
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.3148] audit: op="connection-activate" uuid="45bdf09e-d58f-476b-a1c1-e152c6cb4c21" name="Windows Phone9162" pid=1650 uid=1000 result="success"
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.3163] device (wlp4s0b1): state change: deactivating -> disconnected (reason 'new-activation') [110 30 60]
...
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.3381] manager: NetworkManager state is now DISCONNECTED
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.3383] device (wlp4s0b1): Activation: starting connection 'Windows Phone9162' (45bdf09e-d58f-476b-a1c1-e152c6cb4c21)
Jul 30 16:56:17 localhost.localdomain wpa_supplicant[1129]: wlp4s0b1: Reject scan trigger since one is already pending
Jul 30 16:56:17 localhost.localdomain nm-dispatcher[4491]: req:3 'down' [wlp4s0b1]: new request (5 scripts)
Jul 30 16:56:17 localhost.localdomain nm-dispatcher[4491]: req:3 'down' [wlp4s0b1]: start running ordered scripts...
Jul 30 16:56:17 localhost.localdomain wpa_supplicant[1129]: wlp4s0b1: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <warn>  [1469872577.3464] sup-iface[0x55d400085a00,wlp4s0b1]: connection disconnected (reason -3)
...
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.3493] device (wlp4s0b1): state change: prepare -> config (reason 'none') [40 50 0]
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.3495] device (wlp4s0b1): Activation: (wifi) access point 'Windows Phone9162' has security, but secrets are required.
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.3495] device (wlp4s0b1): state change: config -> need-auth (reason 'none') [50 60 0]
Jul 30 16:56:17 localhost.localdomain NetworkManager[1023]: <info>  [1469872577.3536] device (wlp4s0b1): state change: need-auth -> prepare (reason 'none') [60 40 0]
Jul 30 16:56:17 localhost.localdomain NetworkManager ...
(more)
edit retag flag offensive close merge delete

Comments

You're using the wifi hotspot on your phone or bluetooth tethering?

When you say you can't use it, do you mean you don't see it being available, it can't connect, or something else?

ssieb gravatar imagessieb ( 2016-07-28 14:33:10 -0600 )edit

wifi hotspot on my phone. it's available (the mobile wireless name is detected), but it can't connect

akun gravatar imageakun ( 2016-07-28 22:16:27 -0600 )edit

There's nothing specific to "tethering", it should just be a wifi connection.

In a terminal window as root, run journalctl -fa, then try to connect to the hotspot. See if there are any relevant errors or other messages.

ssieb gravatar imagessieb ( 2016-07-29 14:09:57 -0600 )edit

I update the question with some of the output. Thank you.

akun gravatar imageakun ( 2016-07-30 05:22:49 -0600 )edit

There wasn't anything relevant between the iscsi line and the CONNECTED_LOCAL line? The connection is up, but for some reason shuts down again. Was there a line in the cut out part about CONNECTED_GLOBAL?

ssieb gravatar imagessieb ( 2016-08-04 18:57:47 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-07-30 09:30:08 -0600

updated 2016-07-30 09:31:36 -0600

It looks like Network Manager is not allowing you to connect to your Phone's Wi-Fi network because you don't have the pre-shared key specified in the connection profile.

Are you using the GNOME GUI to configure your wireless connection to your Windows Phone, or are you using the nmcli utility in a terminal session? If you're using nmcli, try using the GNOME GUI utility; it should be easier to set up with GNOME - GNOME should prompt you for that key (the password for your Wi-Fi network provided by your phone). Give it a shot and let us know how it goes.

edit flag offensive delete link more

Comments

If GNOME GUI is the tool at the right corner of the screen, yes, I use the GUI tool. When the laptop is trying to connect to the phone, there is a password textbox appeared which needs to be filled, and I fill the password correctly. I also check the password under "Wi-Fi Settings".

akun gravatar imageakun ( 2016-08-01 09:03:01 -0600 )edit

Can you post the output of nmcli c show 'Windows Phone9162'?

bitwiseoperator gravatar imagebitwiseoperator ( 2016-08-02 09:44:49 -0600 )edit
0

answered 2016-08-02 20:33:39 -0600

akun gravatar image

updated 2016-12-09 23:05:32 -0600

OK, I don't know why. I switched to other distribution (Linux Mint 18) and I found no issue tethering with the Windows Phone. However, recently I installed Fedora 25, tested it (tethering) using my Android smart phone and it works.

I don't know why or whether this is the smart phone or the OS issue. Nevertheless, I am sorry for leaving this question for too long. I think it's time to mark this question as answered in spite of the situation.

Thank you very much.


old (previous) answer:

Here's the output for "nmcli c show" command. I played a little with the connection (tried to reset connection and reconnect the device) and I think the system change the connection profile name from 'WIndows Phone9162' to 'Auto Windows Phone9162', but the SSID still the same.

nmcli c show (some other connections are omitted)

NAME                    UUID                                  TYPE             DEVICE 
Auto Windows Phone9162  8c2435e7-883c-465a-b9a7-ccd711500466  802-11-wireless  --

nmcli c show 'Auto Windows Phone9162'

connection.id:                          Auto Windows Phone9162
connection.uuid:                        8c2435e7-883c-465a-b9a7-ccd711500466
connection.interface-name:              --
connection.type:                        802-11-wireless
connection.autoconnect:                 yes
connection.autoconnect-priority:        0
connection.timestamp:                   1470187018
connection.read-only:                   no
connection.permissions:                 
connection.zone:                        --
connection.master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (default)
connection.secondaries:                 
connection.gateway-ping-timeout:        0
connection.metered:                     unknown
connection.lldp:                        -1 (default)
802-11-wireless.ssid:                   Windows Phone9162
802-11-wireless.mode:                   infrastructure
802-11-wireless.band:                   --
802-11-wireless.channel:                0
802-11-wireless.bssid:                  --
802-11-wireless.rate:                   0
802-11-wireless.tx-power:               0
802-11-wireless.mac-address:            C0:18:85:D2:60:B9
802-11-wireless.cloned-mac-address:     --
802-11-wireless.mac-address-blacklist:  
802-11-wireless.mac-address-randomization:default
802-11-wireless.mtu:                    auto
802-11-wireless.seen-bssids:            3C:83:75:DE:86:A6
802-11-wireless.hidden:                 no
802-11-wireless.powersave:              default (0)
802-11-wireless-security.key-mgmt:      wpa-psk
802-11-wireless-security.wep-tx-keyidx: 0
802-11-wireless-security.auth-alg:      --
802-11-wireless-security.proto:         wpa,rsn
802-11-wireless-security.pairwise:      
802-11-wireless-security.group:         
802-11-wireless-security.leap-username: --
802-11-wireless-security.wep-key0:      <hidden>
802-11-wireless-security.wep-key1:      <hidden>
802-11-wireless-security.wep-key2:      <hidden>
802-11-wireless-security.wep-key3:      <hidden>
802-11-wireless-security.wep-key-flags: 0 (none)
802-11-wireless-security.wep-key-type:  0 (unknown)
802-11-wireless-security.psk:           <hidden>
802-11-wireless-security.psk-flags:     0 (none)
802-11-wireless-security.leap-password: <hidden>
802-11-wireless-security.leap-password-flags:0 (none)
ipv4.method:                            auto
ipv4.dns:                               
ipv4.dns-search:                        
ipv4.dns-options:                       (default)
ipv4.addresses:                         
ipv4.gateway:                           --
ipv4.routes:                            
ipv4.route-metric:                      -1
ipv4.ignore-auto-routes:                no
ipv4.ignore-auto-dns:                   no
ipv4.dhcp-client-id:                    --
ipv4.dhcp-timeout:                      0
ipv4.dhcp-send-hostname:                yes
ipv4.dhcp-hostname:                     --
ipv4.dhcp-fqdn:                         --
ipv4.never-default:                     no
ipv4.may-fail:                          yes
ipv4.dad-timeout:                       -1 (default)
ipv6.method:                            auto
ipv6.dns:                               
ipv6.dns-search:                        
ipv6.dns-options:                       (default)
ipv6.addresses:                         
ipv6.gateway:                           --
ipv6.routes:                            
ipv6.route-metric:                      -1
ipv6.ignore-auto-routes:                no
ipv6.ignore-auto-dns:                   no
ipv6.never-default:                     no
ipv6.may-fail:                          yes
ipv6.ip6-privacy:                       0 (disabled)
ipv6.addr-gen-mode:                     stable-privacy
ipv6.dhcp-send-hostname:                yes
ipv6.dhcp-hostname:                     --
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-28 01:16:35 -0600

Seen: 824 times

Last updated: Dec 09 '16