English
Ask Your Question
0

wireless dropping with atheros card

asked 2012-07-03 15:42:38 +0000

jsuhm gravatar image

Hi,

I'm trying Fedora17 on a new Dell vostro 3360 and I have some issues.

When using the wireless connection after a random time, i'm not able to ping anything.

Thanks in advance for any help / suggestion.


PS : Same issue with many combinations :

  • kernel-3.3.4-5.fc17.x8664 and kernel-3.4.3-1.fc17.x8664
  • multiple ssid / hotspots
  • gnome / kde

More details :

# lspci | grep -i ath
01:00.0 Network controller: Atheros Communications Inc. Device 0034 (rev 01)
02:00.0 Ethernet controller: Atheros Communications Device 1091 (rev 10)

# lsmod | grep -i ath
ath9k                 131114  0 
ath9k_common           13602  1 ath9k
ath9k_hw              389899  2 ath9k_common,ath9k
ath                    23103  3 ath9k_common,ath9k,ath9k_hw
mac80211              497449  1 ath9k
cfg80211              187660  3 ath,ath9k,mac80211

# iwconfig 
lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"xxxxx"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: xx:xx:xx:xx:xx:xx   
          Bit Rate=54 Mb/s   Tx-Power=19 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-32 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:17   Missed beacon:0
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-07-15 18:43:45 +0000

jsuhm gravatar image

Using wicd instead of NetworkManager seems to solve the problem :

yum install wicd wicd-curses wicd-kde wicd-gtk

systemctl disable NetworkManager.service
systemctl disable NetworkManager-wait-online.service 
systemctl stop NetworkManager.service
systemctl stop NetworkManager-wait-online.service

systemctl enable wicd.service
systemctl start wicd.service

In case of selinux issues, you can try this :

restorecon -v '/etc/wicd/manager-settings.conf'
restorecon -v '/etc/wicd/wireless-settings.conf'
restorecon -v '/etc/wicd/wired-settings.conf'
grep wicd /var/log/audit/audit.log | audit2allow -M mypol
semodule -i mypol.pp

If everything works fine, you can remove the NetworkManager applet and add the Wicd applet.

Usefull links :

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2012-07-03 15:42:38 +0000

Seen: 1,215 times

Last updated: Jul 15 '12