Ask Your Question
0

Fedora 18 severe overheating HP Envy 4 1002tx in Gnome shell

asked 2013-02-02 23:51:37 -0600

napsternxg gravatar image

updated 2014-09-28 14:22:22 -0600

mether gravatar image

I recently installed Fedora 18 x86_64bit version in dual boot mode on my HP Envy 4 1002tx machine and whenever I log into the Gnome shell I am facing very sever overheating of my laptop base and the there is a very loud sound like a very fast moving fan coming from the laptop.

Full specs of my laptop can be found at: http://h10025.www1.hp.com/ewfrf/wc/document?cc=us&lc=en&dlc=en&docname=c03342406

This only happens when I am booting using the new Gnome graphics mode. If I boot into the just the command line interface or into the downgraded Gnome interface the laptop heating issue are not experienced.

My laptop has AMD Radeon HD 7670M (2 GB DDR3 dedicated) graphics card and I have never faced any issue of overheating in my windows 8 installation. Other important configurations are: Microprocessor 1.7 GHz Intel Core i5-3317U Microprocessor Cache 3 MB L3 cache Memory 4 GB 1600 MHz DDR3

Because of the overheating I am also facing a very low battery life and it sustains only for 2 hours as opposed to the 5-6 hours in general.

I also tried installing the ATI radeon drivers using all the various methods like: 1. kmod-catalyst 2. akmod-catalyst 3. Official driver for linux from ATI site.

In all cases I ran into config issues which could only be resolved after deleting the Xorg.conf file.

After using all the 3 approaches above on rebooting I lost the gnome shell and my system will not bring up gnome. After deleting the xorg.conf I was able to get into gnome but was only presented with the downgraded version of gnome in which the system settings feature stopped working.

I like the gnome 3.6.2 interface and would want to stick to it that is why I am still running my laptop in Fedora irrespective of the overheating issue.

Looking forward to a solution or advice on how to solve this problem.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-03 02:26:31 -0600

napsternxg gravatar image

The issue has been resolved by installing the Gnome Shell Extension - Radeon Power Profile Manager and selecting Set profile to "low" option in it.

Now the overheating has gone and the battery backup has gone back to 5 hr 56 minutes

More details can be found at: http://smexyyweby.wordpress.com/2013/02/03/resolve-overheating-issue-for-amd-radeon-graphics-card-for-gnome-3-6-in-fedora-18/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-02 23:51:37 -0600

Seen: 1,532 times

Last updated: Feb 03 '13