English
Ask Your Question
1

ftp transfer eats all my bandwidth

asked 2011-12-15 17:47:10 +0000

ztank1013 gravatar image

updated 2011-12-15 18:25:55 +0000

Every time I use Nautilus in my fedora 16 to connect (ftp with authentication) to a remote server and make an upload, it works but while the file is transfered from my machine to the remote server I have my upload bandwidth totally used (which I believe is the expected behavior) but downloading bandwidth is almost unused.

Here's come the annoying part: as a side effect my web navigation and any other incoming network traffic is incredibly slowed down. Loading a 100KB html page may take minutes.

Of course everything gets back to normality once the ftp upload ends. I already tried to re-nice (20) the ftp process to see if this will give a little more space/bandwidth to other processes (for example firefox) but it didn't work...

Any thoughts?

edit retag flag offensive close delete

Comments

Are you on xDSL?

lzap ( 2011-12-15 19:47:18 +0000 )edit

@lzap Asymmetric Digital Subscriber Line, when I used Ubuntu I did not have this problem though...

ztank1013 ( 2011-12-15 19:54:17 +0000 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-12-16 00:33:53 +0000

updated 2011-12-16 00:38:47 +0000

I recommend using FileZilla instead, with it you can limit your upload rate, and this way you will not choke your BW.

P.S Rule of thumb, limit your upload to 80% of your total upload BW.

i.e I have a Cable connection of 2.5Mb/250kb so i limit my upload to 25KiB

edit flag offensive delete publish link more

Comments

@The IceMan Blog Nice option, I did not know Filezilla had that option. I usually use scp .

bodhi.zazen ( 2011-12-16 16:18:54 +0000 )edit
1

answered 2011-12-15 20:30:53 +0000

updated 2011-12-15 20:33:47 +0000

The problem you are having is that your ftp transfer is using your upload bandwidth (as you can see).

What you want to do to help with the problem is called traffic shaping.

You can use a number of tools to help.

1) lftp

edit /etc/lftp.conf and add a line

set net:limit-rate <bytes per sec>

2) trickle - you will need to install trickle first

trickle -d <kbytes/sec> ftp

Edit : trickle tutorial - http://www.go2linux.org/traffic-shaping-with-linux

3) tc is a bit more complex. See See http://www.cyberciti.biz/faq/linux-traffic-shaping-using-tc-to-control-http-traffic/

You will have to try adjusting the limits for your network.

edit flag offensive delete publish link more

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2011-12-15 17:47:10 +0000

Seen: 537 times

Last updated: Dec 16 '11