Ask Your Question
1

Failed to synchronize cache for repo

asked 2016-08-14 13:20:46 -0500

tjclark gravatar image

Whenever I run dnf install/search/etc... I get this message after about a minute of silence for virtually every repo I have in /etc/yum.repos.d:

Failed to synchronize cache for repo 'mhoeher-multitouch', disabling.
Failed to synchronize cache for repo 'helber-atom', disabling.
Failed to synchronize cache for repo 'rpmfusion-nonfree-updates', disabling.
Failed to synchronize cache for repo 'rpmfusion-free-rawhide', disabling.
Failed to synchronize cache for repo 'fedora-nvidia', disabling.
Failed to synchronize cache for repo 'rpmfusion-free', disabling.
Failed to synchronize cache for repo 'rpmfusion-nonfree', disabling.
Failed to synchronize cache for repo 'rpmfusion-free-updates-testing', disabling.
Last metadata expiration check: 0:02:23 ago on Sun Aug 14 14:08:31 2016.
Error: No matches found.

I did run dnf clean all && dnf check-update

I checked the URLs for each manually, and they all exist and have a repodata/repomd.xml

I'm not using a proxy

I think this really points towards a bug in dnf, but I'm not sure what to do about it. Any ideas? Could it possibly actually be something I can fix by reconfiguring?

edit retag flag offensive close merge delete

Comments

Are you connected to the internet? Is your DNS (or the one of your internet service provider) working fine? Does ping redhat.com return something positive?

florian gravatar imageflorian ( 2016-08-15 09:14:30 -0500 )edit

Yes, I am connected to the internet. Like I said, I can get download repomd.xml from each of the repositories using a web browser or curl, so it's not a connection issue nor is the repository down.

tjclark gravatar imagetjclark ( 2016-08-15 18:28:10 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-08-15 19:53:19 -0500

tjclark gravatar image

I got it.

DNF has been trying to use IPv6 to download repo data, which my router doesn't support. To fix it, I added:

ip_resolve=4

to /etc/dnf/dnf.conf

edit flag offensive delete link more
0

answered 2016-08-15 02:45:53 -0500

davidva gravatar image

?? 'rpmfusion-free-rawhide'?? man! are you in rawhide? and "'rpmfusion-free-updates-testing"?? and "fedora-nvidia? man disable it...

You can read here How to enable/disable repositories

edit flag offensive delete link more

Comments

I disabled those repositories, but reasonable ones like rpmfusion-free are still not working

tjclark gravatar imagetjclark ( 2016-08-15 18:37:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-08-14 13:20:46 -0500

Seen: 15,394 times

Last updated: Aug 15 '16