Ask Your Question
1

Permanently set up wakeup-on-LAN (WoL)

asked 2011-12-14 10:51:53 -0500

fheub gravatar image

What is the proper way to prepare my desktop machine for wakeup-on-LAN (WoL) in times of systemd (Fedora 16)?

While I can enable it for my ethernet device using ethtool -s em1 wol g and succesfully wake from an other machine on the network, I found no permanent setting i.e. after waking up ethtool em1 | grep -i wake is changed back to:

Supports Wake-on: pg
Wake-on: d

I found a hint at blog.nirkabel.org, but could not figure out how to make it work for me. Here is what I tried: I added a line to /etc/sysconfig/network-scripts/ifcfg-em1:

ETHTOOL_OPTIONS="wol g"

Any suggestions? Thank you for your consideration!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-12-14 15:03:18 -0500

SoumyaC gravatar image

Hopefully above you have done

ETHTOOL_OPTS="wol g"

and bounced the network Service ? (Hope the above ETHTOOL OPTIONS is a typo) If after setting ETHTOOL_OPTS (not OPTIONS) in ifcfg-em1 didn't work for you then try putting this small line in /etc/rc.d/rc.local

/usr/sbin/ethtool -s em1 wol g

The above line considers your Ethernet device to be "em1".

If still doesn't work you can add all the wake up related config details in rc.local file as mentioned in the below link -

WOL

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-14 10:51:53 -0500

Seen: 12,448 times

Last updated: Dec 14 '11