English
Ask Your Question
3

yum update error: cannot retrieve metalink for repository: fedora.

asked 2011-12-31 16:40:45 +0000

macroron gravatar image

updated 2013-02-15 17:15:10 +0000

mether gravatar image

[Info]

$ uname -a

Linux f16.home.net 
3.1.6-1.fc16.x86_64 #1 SMP 
Wed Dec 21 22:41:17 UTC 2011 
x86_64 x86_64 x86_64 GNU/Linux

[Problem]

$ sudo yum update
Error: Cannot retrieve metalink for repository: fedora. Please verify its path and try again

[Temporary Fix To Use Yum Online]

Masked "#mirrorlist=" and unmasked "baseurl=" in '/etc/yum.repos.d/fedora.repo' '/etc/yum.repos.d/fedora-updates.repo'

[Investigation]

$ rpm -q nss

nss-3.13.1-9.fc16.x86_64

$ URLGRABBER_DEBUG=1 yum check-update

...

* About to connect() to mirrors.fedoraproject.org port 443 (#0)
*   Trying 152.19.134.146... * connected
* Connected to mirrors.fedoraproject.org (152.19.134.146) port 443 (#0)
* warning: ignoring unsupported value (1) of ssl.verifyhost
* NSS error -5978

* Closing connection #0
* Problem with the SSL CA cert (path? access rights?)
2011-12-31 14:00:09,652 exception: [Errno 14] curl#77 - "<Unknown>"
INFO:urlgrabber:exception: [Errno 14] curl#77 - "<Unknown>"
2011-12-31 14:00:09,652 retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-raising
INFO:urlgrabber:retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-raising
Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=updates-released-f16&arch=x86_64 error was
14: curl#77 - "<Unknown>"

...

There seemed to be an SSL CA cert problem on my end.

Chrome browser is working ok.

I tried links lynx and elinks and they all couldn't connect with SSL errors.

I recently configured msmtp mail(mta) and may have inadvertently mess up in '/etc/pki/tls/certs/'

[Solution]

$ rpm --query --file  /etc/pki/tls/certs/ca-bundle.trust.crt
ca-certificates-2011.78-1.fc16.noarch

$ sudo yum reinstall ca-certificates-2011.78-1.fc16.noarch
Installed:
  ca-certificates.noarch 0:2011.78-1.fc16

Complete!

[Solved]

edit retag flag offensive close delete

Comments

@macroron Could you please attach your complete mirrorlist lines?

ztank1013 ( 2011-12-31 17:59:37 +0000 )edit

After going through these steps and changing my .repo files back to the original, the error comes back...

GergelyPolonkai ( 2012-12-02 02:06:12 +0000 )edit

Please don't rename the title to "Solved" unnecessarily. Just mark the answer you prefer and that will be enough to note that this question has been answered to your satisfaction.

mether ( 2013-02-15 17:15:56 +0000 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2011-12-31 18:55:01 +0000

In errors like this, I always like to use urlgrabbers debug mode:

URLGRABBER_DEBUG=1 yum check-update

and look for lines with error in them. This will usually tell you what the exact issue is with downloading the mirrorlists.

edit flag offensive delete publish link more
0

answered 2015-01-09 12:53:14 +0000

Getting this error, I uninstalled the epel repository (otherwise yum can't be used):

rpm -ev epel-release-6-8.noarch

Then update the ca-certificates package:

yum update ca-certificates

The reinstall the epel repository

rpm -ihv epel-release-6-8.noarch.rpm

And everything worked.

edit flag offensive delete publish link more

Comments

EPEL is Extra Packages for Enterprise Linux. That means RHEL, and derivatives like CentOS. You should not be using EPEL on Fedora - it is a repository intended for an entirely different operating system.

randomuser ( 2015-01-09 13:57:10 +0000 )edit
0

answered 2014-11-25 07:03:31 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

updated 2014-11-25 07:03:31 +0000

Manas gravatar image

If you are getting this Error as follow while Yum Update or yum install : Error: Cannot retrieve metalink for repository: fedora/18/x86_64. Please verify its path and try again

Answer : Please check your Proxies i.e env variables 1. http_proxy 2. https_proxy 3. http_proxy in the /etc/yum.conf

Enter the proxy like : export http_proxy=xxx.xxx.xxx.xxx:port_no export https_proxy=xxx.xxx.xxx.xxx:port_no

edit flag offensive delete publish link more

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2011-12-31 16:40:45 +0000

Seen: 71,648 times

Last updated: Jan 09