Ask Your Question
0

How do I enable touchpad while typing?

asked 2016-08-26 12:58:40 -0500

lamo gravatar image

I've wanted to play a game, but there is a problem. When I want to turn and walk at same time, I can't, because the touchpad do not work when walking. I've ridden that synclient and syndaemon can fix this, but I don't know how to use them and they require synaptics driver, and I don't know how to load driver. Can someone help me, please?

edit retag flag offensive close merge delete

Comments

Did you check in the "Mouse and Touchpad" configuration, then "Toucpad" tab and uncheck "Disable Touchpad while typing".

thomaswood gravatar imagethomaswood ( 2016-08-27 07:51:13 -0500 )edit

There isn't any ''Disable touchpad while typing'' entry in GNOME Settings and ''Mouse and Touchpad'' configuration do not work on other desktops, such as IceWM.

lamo gravatar imagelamo ( 2016-08-27 10:32:44 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-08-29 08:45:25 -0500

With the libinput driver :

In a terminal xinput list => to get the id number of your touchpad. Example : ↳ ETPS/2 Elantech Touchpad id=12

then xinput list-props 12 => to display all options with 12 as the id from previous step. Check this line libinput Disable While Typing Enable (292): 1

To change the value : xinput set-prop 12 292 0 => no reboot required. Just test it.

edit flag offensive delete link more

Comments

Please don't use the numbers, they're prone to change. Use the device name and the property name and it'll work the same way.

http://who-t.blogspot.com.au/2016/07/...

whot gravatar imagewhot ( 2016-09-01 23:15:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-26 12:58:40 -0500

Seen: 1,186 times

Last updated: Aug 29 '16