English
Ask Your Question
0

wifi strength is too low Realtek RTL8723BE

asked 2016-08-30 10:09:14 +0000

user0016 gravatar image

updated 2016-08-30 20:22:45 +0000

Hi all, I have a Hp pavilion laptop.I installed fedora 23 few days ago dual boot with Windows 8.1. Now i am facing problem in wireless signal strength in fedora . Laptop is unable to pick up signal(very low signal ) near to the router. But at the same time in window gets full strength signal. I don't find any solution . please kindly help me in this regard.I am waiting for your response.

Thank you Cp

edit retag flag offensive close merge delete

Comments

While not sure how to help you it will be best if you provide us with your wifi card manufacture and model, to get that on a terminal do sudo lspci | grep Wireless and paste the output here.

aeperezt ( 2016-08-30 15:50:39 +0000 )edit

this is the configuration i get

08:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

user0016 ( 2016-08-30 18:14:28 +0000 )edit

My solution for my Toshiba laptop was to replace the Realtek card with an Intel card. Problem solved.

Glenn ( 2017-03-19 08:40:07 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2017-03-18 01:15:16 +0000

tim8723 gravatar image

updated 2017-03-19 00:00:51 +0000

I have an HP Probook with the same wireless card and I had the same problem. Using modprobe options ant_sel=1 and fwlps=0 gave me a much better connection. If ant_sel=1 does not help, try 2 - it just depends which antenna port the antenna is plugged into on the card.

In Windows, the driver handles this automatically.

edit flag offensive delete link more
0

answered 2017-03-19 04:27:01 +0000

Hi, My laptop has the exactly same wireless card and I too had the same problem. It appears there is some issue with power management in the driver.

I used fwlps=0 iwlps=0 to get a stable connection.

Create a file /etc/modprobe.d/rtl8723be.conf and add the following to it:

options rtl8723be fwlps=0 iwlps=0

I did not have to, but you can try adding ant_sel=1 as tim8723 suggested

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2016-08-30 10:09:14 +0000

Seen: 225 times

Last updated: Mar 19