Ask Your Question
1

Gnome 3 does not follow the goemetry of vncserver

asked 2012-09-13 10:35:36 -0500

ericzma gravatar image

On Fedora 17 with Gnome 3, I try to start a vncserver with

$ vncserver -geometry 1024x768

to start a vnc server with geometry 1024x768.

However, after I connect to the vnc server, the resolution is not 1024x768. I change the geometry to other resolution and the actual resolution is not changed.

I changes the desktop environment for vnc server to twm and the geometry takes effect.

Does anyone have the same problem with me? And any suggestion? Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-11-16 07:30:00 -0500

ThinLinc gravatar image

Gnome (and other modern DE:s) have the tendency to resize your VNC session. The reason being that when a user logs in to his machine the "normal" way, he/she generally wants the resolution they had the last time restored.

In Gnome's case, these settings are stored in ~/.config/monitors.xml. Try moving that out of the way and see if it improves.

edit flag offensive delete link more

Comments

1

thanks, I can confirm this solution working on fedora 21 without monitor or boot gui

stovekov gravatar imagestovekov ( 2015-01-13 13:50:23 -0500 )edit

@stovekov Great to know that.

ericzma gravatar imageericzma ( 2015-01-19 08:53:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-09-13 10:35:36 -0500

Seen: 1,335 times

Last updated: Nov 16 '12