Ask Your Question
2

Can't Select "Picture" Wallpaper in Fedora 18

asked 2013-02-01 07:55:48 -0500

fergatron gravatar image

updated 2013-02-08 09:28:01 -0500

ryanlerch gravatar image

Hi All,

I'm running Fedora 18 and for some reason I can't select or load any pictures as wallpaper using the system settings. If I right-click on a picture I can set it as a wallpaper just fine, but I can't seem to load all my favorite pictures like it does for the base wallpapers and colors options.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2013-02-05 13:30:46 -0500

ryanlerch gravatar image

updated 2013-02-06 10:41:19 -0500

The wallpaper choosing dialog has changed a little bit in Fedora 18 (GNOME 3.6). However, when choosing a wallpaper, I get three "tabs" at the top of the "Select Background" dialog that give me the option to choose between Wallpapers (the system wide stock ones), Pictures (GNOME searches for these pictures in the "Pictures" folder in your home directory), and Colors (block colours and gradients).

So if you put the Photos that you want as the wallpapers in your Pictures folder, they should appear under the "Pictures" tab in this dialog: image description

UPDATE

It also seems that if you have pictures in sub-directories, GNOME will not show them in the Pictures tab. This is a bug that has been previously filed in the GNOME bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=682126

Also, GNOME will not show images that have been taken with the gnome screenshot tool. ( I filed a bug for this -- https://bugzilla.gnome.org/show_bug.cgi?id=693228 ), but this is intended behaviour for GNOME, so it is now closed NOTABUG.

If you really want a screenshot as a background, you can workaround this by opening your image in the GIMP and exporting it back to the same file with "File > Export to yourfilename.png" in the GIMP. This will trick GNOME into showing the file in the Pictures tab.

edit flag offensive delete link more

Comments

2

+1 for filing the bug!

randomuser gravatar imagerandomuser ( 2013-02-06 01:49:01 -0500 )edit

it seems that it is not really a bug. GNOME just does not show images that were put in Pictures by the screenshot tool :/

ryanlerch gravatar imageryanlerch ( 2013-02-06 10:20:19 -0500 )edit

yeah, it seems pretty restrictive to me too. :(

this is the bug for the issue, hopefully if we comment on there, we will be heard :) https://bugzilla.gnome.org/show_bug.cgi?id=682126

ryanlerch gravatar imageryanlerch ( 2013-02-08 09:25:59 -0500 )edit

yeah, it seems pretty restrictive to me too. :(

ryanlerch gravatar imageryanlerch ( 2013-02-08 09:26:00 -0500 )edit
0

answered 2013-03-25 07:51:52 -0500

It's annoying, but you can set the background to a file in whatever directory you want by using gsettings

gsettings set org.gnome.desktop.background picture-uri 'file:///home/jwalker/Documents/Personal/Pictures/Wallpapers/trip_into_woods-1280x720.jpg'
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-01 07:55:48 -0500

Seen: 6,379 times

Last updated: Mar 25 '13