Ask Your Question
1

problem with time and date

asked 2013-02-20 09:40:01 -0600

ShUbHaiN gravatar image

updated 2013-06-06 00:11:29 -0600

I have dual boot my laptop(fedora 18+ windows 7 ultimate).when i change time in fedora automatically time of windows change which is wrong and when i change the time in windows, fedora automatically changes time. In short i am unable to set correct time in both os. is there any solution? i am using dell laptop.

edit retag flag offensive close merge delete

Comments

change time and date from BIOS, next change on Fedora, next Windows (also disable synchronization with web)

davidva gravatar imagedavidva ( 2013-02-20 12:34:37 -0600 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2013-02-20 13:04:15 -0600

jmt gravatar image

Windows computers (at least up to WinXP) keep the system clock at local time while Unix type systems such as Fedora 18 would like to keep the system clock at universal time (UTC). If this is also true for Windows 7, you can command your Fedora installation to use local time as well:

timedatectl set-local-rtc 1
edit flag offensive delete link more

Comments

I generally uncheck the "system clock uses UTC" box in all my distros.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-02-21 06:58:37 -0600 )edit

It appears that the systemd migration "timedatectl" now must be used instead of system-config-date or files in /etc/sysconfig. I think the installer detected Windows 7 was installed and switched the RTC to local while I preferred RTC in UTC. Just set the above value to 0 to reverse this.

ework gravatar imageework ( 2014-01-28 03:57:45 -0600 )edit
1

answered 2013-02-21 03:11:40 -0600

Aleksandar Kostadinov gravatar image

updated 2013-02-21 03:12:14 -0600

As well it seems windows 7 does support system clock at UTC. I think this is preferable to keep your system clock sane. Put this in a file and import in registry:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
“RealTimeIsUniversal”=dword:00000001

References: sorry, can't publish the links but easily found with a search engine

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-20 09:40:01 -0600

Seen: 4,202 times

Last updated: Jun 06 '13