Ask Your Question
1

rpmfusion on F25, how

asked 2016-10-29 09:27:08 -0500

fedoramonsecond gravatar image

after enabling both free and nonfree RPMfusion repos on my fedora 25 I use the suggested command for installing everything:

dnf install gstreamer{1,}-{plugin-crystalhd,ffmpeg,plugins-{good,ugly,bad{,-free,-nonfree,-freeworld,-extras}{,-extras}}} libmpg123 lame-libs --setopt=strict=0

As by here

but I get that a lot of packages are not available:

No package gstreamer1-plugin-crystalhd available.
No package gstreamer1-ffmpeg available.
Package gstreamer1-plugins-good-1.9.2-1.fc25.x86_64 is already installed, skipping.
No package gstreamer1-plugins-bad available.
No package gstreamer1-plugins-bad-extras available.
Package gstreamer1-plugins-bad-free-1.9.2-2.fc25.x86_64 is already installed, skipping.
No package gstreamer1-plugins-bad-nonfree-extras available.
No package gstreamer1-plugins-bad-freeworld-extras available.
No package gstreamer1-plugins-bad-extras available.
No package gstreamer1-plugins-bad-extras-extras available.
No package gstreamer-plugins-bad-nonfree-extras available.
No package gstreamer-plugins-bad-freeworld available.
No package gstreamer-plugins-bad-freeworld-extras available.
No package gstreamer-plugins-bad-extras-extras available.

Please, what should I do? Many thanks :)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-10-30 01:38:02 -0500

Period22 gravatar image

updated 2016-10-30 01:38:45 -0500

An alternative to rpmfusion would be https://unitedrpms.github.io/. They are ready for F25 now.

edit flag offensive delete link more

Comments

It would be a poor alternative.

geforce gravatar imagegeforce ( 2016-10-30 02:50:42 -0500 )edit
1

Why? Works for me.

Period22 gravatar imagePeriod22 ( 2016-10-30 03:58:45 -0500 )edit
1

Apart from the question which repository to use, I get what I need with this command:

sudo dnf install gstreamer1-libav gstreamer1-plugins-bad-free-extras gstreamer1-plugins-bad-freeworld gstreamer1-plugins-good-extras gstreamer1-plugins-ugly ffmpeg

These are all available in rpmfusion for F25, too.

Period22 gravatar imagePeriod22 ( 2016-10-30 04:39:27 -0500 )edit

except for the not so good english what is wrong with United RPMS? They seem to provide everything..

fedoramonsecond gravatar imagefedoramonsecond ( 2016-10-30 05:42:56 -0500 )edit

@leigh123linux ; sure hahaha, F24/F25/F26 packages available, not monoply ;)

davidva gravatar imagedavidva ( 2016-11-01 14:21:04 -0500 )edit
1

answered 2016-10-30 02:48:50 -0500

geforce gravatar image

You are using a dumb command that tries to install non existent packages

You would get the same on F24

[leigh@main_pc ~]$ sudo dnf list gstreamer* |grep rpmfusion
gstreamer-ffmpeg.x86_64                   0.10.13-15.fc24 @rpmfusion-free       
gstreamer-plugins-bad.x86_64              0.10.23-7.fc24  @rpmfusion-free       
gstreamer-plugins-bad-nonfree.x86_64      0.10.23-3.fc24  @rpmfusion-nonfree    
gstreamer-plugins-ugly.x86_64             0.10.19-19.fc24 @rpmfusion-free       
gstreamer1-plugins-bad-freeworld.x86_64   1.8.2-1.fc24    @rpmfusion-free-updates
gstreamer1-plugins-bad-nonfree.x86_64     1.8.2-1.fc24    @rpmfusion-nonfree-updates
gstreamer1-plugins-ugly.x86_64            1.8.2-1.fc24    @rpmfusion-free-updates
gstreamer-ffmpeg.i686                     0.10.13-15.fc24 rpmfusion-free        
gstreamer-plugins-bad.i686                0.10.23-7.fc24  rpmfusion-free        
gstreamer-plugins-bad-nonfree.i686        0.10.23-3.fc24  rpmfusion-nonfree     
gstreamer-plugins-ugly.i686               0.10.19-19.fc24 rpmfusion-free        
gstreamer-plugins-ugly-devel-docs.noarch  0.10.19-19.fc24 rpmfusion-free        
gstreamer1-libav.i686                     1.8.2-1.fc24    rpmfusion-free-updates
gstreamer1-libav-devel-docs.noarch        1.8.2-1.fc24    rpmfusion-free-updates
gstreamer1-plugins-bad-freeworld.i686     1.8.2-1.fc24    rpmfusion-free-updates
gstreamer1-plugins-ugly.i686              1.8.2-1.fc24    rpmfusion-free-updates
gstreamer1-plugins-ugly-devel-docs.noarch 1.8.2-1.fc24    rpmfusion-free-updates
[leigh@main_pc ~]$
edit flag offensive delete link more

Comments

thanks but unfortunately the dumb command is in a askfedora sticky. I wish the would provide an updated command on rpmfusion website. Fedora is such a nice distro, even for newbies, especially if you love Gnome. And once "installed" rpmfusion codec packages you have a pefect desktop machine. Fedora or RPMfusion should consider providing more updated sticky infos imho :) (as they do at unitedrpms)

fedoramonsecond gravatar imagefedoramonsecond ( 2016-10-30 05:41:12 -0500 )edit

Just because the command is "dumb" does not mean it's not working correctly. The command simply tries to install all various combinations of package names, and not all of them exist. Therefore a "--setopt=strict=0" was added, so dnf will continue to install the (existing) packages anyway. In short: The command is fine and all is as it should be. Just continue to install the packages.

Axel Sommerfeldt gravatar imageAxel Sommerfeldt ( 2016-11-01 04:06:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-29 09:25:50 -0500

Seen: 2,111 times

Last updated: Oct 30 '16