Ask Your Question
1

Can't get dnsmasq to work

asked 2016-11-15 11:27:43 -0500

timon gravatar image

I recently switched from macOS to Fedora 24, and I'm getting pretty comfortable with my new environment.

On my macOS environment I used dnsmasq to wildcard *.dev domains to 127.0.0.1 with the following rule: address=/dev/127.0.0.1

So I made sure the service is enabled and running, by running the following commands:

systemctl enable dnsmasq.service

systemctl start dnsmasq.service

systemctl restart dnsmasq.service

Now when I run ping test.dev, I get not the wanted result. It pings to 127.0.53.53, the wanted result is of course 127.0.0.1. I know that 127.0.53.53 is the same as 127.0.0.1. That doesn't mean that it's all fine, because what that means, is that dnsmasq is not working.

Have I missed a step around here?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2016-11-16 05:38:35 -0500

Aeyoun gravatar image

updated 2016-11-16 05:39:05 -0500

I’m assuming you’re using Fedora Workstation. You should configure dnsmasq through NetworkManager rather than run it on it’s own service. You’ll avoid conflicts that way. NetworkManager really likes being involved in everything.

edit flag offensive delete link more

Comments

Configuring dnsmasq through NetworkManager did the job. I ended up making the custom configuration in /etc/NetworkManger/dnsmasq.d/. Thanks a lot!

timon gravatar imagetimon ( 2016-11-16 07:04:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-11-15 11:27:43 -0500

Seen: 270 times

Last updated: Nov 16 '16