Ask Your Question

vmware horizon Client Fedora 24

asked 2016-11-17 21:09:08 +0000

Lansoar gravatar image


I am trying to install VMware Horizon client. During the installation, the installer scans and attempts to register the software. the scan fails with the following text:

VMware Horizon PCoIP Failed libffi.so.5 VMware Horizon Client Failed libudev.so.0

When attempting to run the client from Applications....clicking on the horizon icon causes a flash, then nothing. running from Terminal gets the following:

vmware-view /usr/lib/vmware/view/bin/vmware-view: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory

I found some guides for making it run but only up to Fedora 21. Any help appreciated.

edit retag flag offensive close merge delete


There is compat-libffi in f23 you can try download and install, and libudev0 from opensuse. You can download them and install with: dnf install compat-libffi-3.0.10-7.fc23.x86_64.rpm and dnf install libudev0-182-5.3.9.x86_64.rpm and pray it works. Good luck.

fcomida ( 2016-11-18 01:49:08 +0000 )edit

Thank you!

I was unable to download/install them using dnf (error:cannot load RPM) but was able to download and install the two mentioned items directly from opensuse using package installer. Reinstalling the horizon client gave success messages after scanning for both client and PCoIP.

Was successful in connecting to the remote server using Horizon but got black screen followed by a disconnect when the client would attempt to display the remote desktop. installing rdesktop and using RDP resolved. Thanks again for your help.

Lansoar ( 2016-11-18 03:16:22 +0000 )edit

Just to clarify, first you must download the packages and then install them locally with dnf with the command above if your packages are in the current working directory, providing their path to dnf otherwise.

fcomida ( 2016-11-18 12:11:07 +0000 )edit

3 answers

Sort by ยป oldest newest most voted

answered 2016-12-29 09:44:40 +0000

shaam gravatar image


This worked for me:

sudo ln -s /usr/lib64/libgudev-1.0.so.0 /usr/lib64/libudev.so.0 src:sudo ln -s /usr/lib64/libffi.so.6 /usr/lib64/libffi.so.5

And if necassary sudo ln -s /usr/lib64/libffi.so.6 /usr/lib64/libffi.so.5


edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.


Asked: 2016-11-17 21:09:08 +0000

Seen: 1,477 times

Last updated: Nov 17 '16