Ask Your Question
0

Problem updating from F24 to F25

asked 2016-11-23 07:14:07 -0500

keramidas gravatar image

When I try to update to F25 I get the following error:

sudo dnf system-upgrade download --refresh --releasever=25

Last metadata expiration check: 0:00:14 ago on Wed Nov 23 15:07:17 2016. Error: package rpm-python-4.13.0-1.fc24.x86_64 requires rpm = 4.13.0-1.fc24, but none of the providers can be installed. package rpm-python3-4.13.0-1.fc24.x86_64 requires rpm = 4.13.0-1.fc24, but none of the providers can be installed (try to add '--allowerasing' to command line to replace conflicting packages)

If I add the -allowerasing option the rpm-python and rpm-python3 packages get removed, which i do not believe is a good idea.

Do you have any idea on how to solve this conflict?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-23 14:15:57 -0500

hhlp gravatar image

This happened to me too, this problem because you update your system from a FEDORA 24 testing repo an your version is newer than the exist in fedora 25, the solution is simple, just downgrade your packages :

sudo dnf downgrade rpm

and then do again

sudo dnf system-upgrade download --refresh --releasever=25

Regards.,

NOTE : there is a bug open in readhat bugzilla about that problem but now i can't find it...

edit flag offensive delete link more
0

answered 2016-11-23 13:43:12 -0500

vmeson gravatar image

This bug was acknowledge in the comments here: https://fedoramagazine.org/upgrading-... The advice was to wait a day or two. :(

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-23 07:14:07 -0500

Seen: 170 times

Last updated: Nov 23 '16