English
Ask Your Question
1

How do I get a working graphical desktop on F25 Server Edition?

asked 2016-11-26 03:57:10 +0000

ykill gravatar image

I would like to install fedora-server and still have a graphical desktop. Starting with fedora 25 server edition, I tried including extra software packages within the installer. I afterwards went in and tried groupinstalling fedora-workstation. However, there is no X or wayland happening. Will I have to do some actual work picking out packages, or do I simply need to mess around with systemd?

edit retag flag offensive close merge delete

Comments

dnf grouplist then pick up your preferred DE and install it with dnf groupinstall "YOUR_DE_GROUP_NAME"

fcomida ( 2016-11-26 12:52:54 +0000 )edit

@fcomida I did try that, but afterwards when I changed to the graphical.target, it wouldn't go, even marking it as default. See my answer below, and thank you!

ykill ( 2016-11-26 13:53:49 +0000 )edit

startx from a terminal should launch your DE under X (GNOME since you groupinstalled fedora-workstation), i don't know how to launch a wayland session from the terminal. Try that and look at any errors, look at your logs too afterwards.

fcomida ( 2016-11-26 14:12:42 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-11-26 14:09:01 +0000

ykill gravatar image

I solved this myself, and here's what I did:

First, use the graphical installer for fedora25 server. Then install things as @fcomida suggested

# sudo dnf groupinstall "Development and Creative Workstation" gnome LibreOffice

This worked. I had thought I could simply install the group Fedora Workstation after installing server edition, but it didn't work for me. I added gnome for good measure, and LibreOffice since I'll install that anyway.

Immediately after this, I was able to go to graphical.target and gdm started. I can also use cockpit to learn about server stuff. I set graphical.target as default, and now I have my graphical desktop running on my "server!"

edit flag offensive delete link more
1

answered 2016-11-26 04:43:54 +0000

porfiriopaiz gravatar image

First of all install GNOME Shell Desktop Environment:
su -c 'dnf group install workstation-product-environment'

Then, you will have to set Graphical Login as Default:
su -c 'systemctl set-default graphical.target'

And also you might have to enable gdm.service:
su -c 'systemctl enable gdm.service'

Hope this help.

edit flag offensive delete link more

Comments

That's what I was looking for: "workstation-product-environment." I haven't tested it, but this is probably correct. I had already tried your second and third lines, without success.

ykill ( 2016-11-29 04:12:25 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2016-11-26 03:57:10 +0000

Seen: 5,128 times

Last updated: Nov 26 '16