English
Ask Your Question
0

Screen resolution not applied F17

asked 2012-06-20 02:54:00 +0000

malak gravatar image

I filed a bug for this but there is no answer, not even a few questions to provide extra details.

https://bugzilla.redhat.com/show_bug.cgi?id=831020

Description of problem:

I have set a screen resolution of 1280x1024 (5x4) on my Samsung SyncMaster 750s (circa year 2000). Fedora 17 x86_64 Gnome 3.4. When the screen saver and screen lock engage, after I enter my password to unlock the screen the 1280x1024 (5x4) resolution is no longer available and the screen defaults to 1024x768 (4x3). Should the machine reboot, the first login will come up again with the desired 1280x1024 (5x4) resolution.

Previously, this was (curiously) "corrected" by (each time after unlocking the screen) going into the Applications / System Tools / System Settings / Displays in order to manually correct the problem; however, besides this being undesirable, the system would automatically correct the screen resolution before I could click the "apply" button.

Version-Release number of selected component (if applicable):

17 x64

How reproducible:

always

Steps to Reproduce: 1. boot machine -- correct screen resolution is applied 2. allow screensaver to engage 3. enter password to unlock screen

Actual results:

higher resolutions are not available and screen defaults to 1024 x 768

Expected results:

1280x1024 (5x4) resolution would remain.

Additional info:


Followup comments from me:

malak@malak.ca 2012-06-12 20:16:45 EDT

Inexplicably and despite the lack of any updates, I now can't reproduce this bug since the "expected result" of keeping the 5:4 resolution is occuring.

[reply] [-] Comment 2 malak@malak.ca 2012-06-13 07:40:12 EDT

... and now overnight it has reproduced itself.

[reply] [-] Comment 3 malak@malak.ca 2012-06-18 07:13:47 EDT

just upgraded to kernel 3.4.2-4.fc17.x86_64 and rebooted

As described, the desired screen size of 5:4 has returned on its own. I have tried to do a screen lock via the menu in the upper right hand corner, and this does not cause the system to "forget" the screen resolution settings, as mentionned above. I will see if allowing the system to do its own automatic screen lock will reproduce it again, which I expect will be the case.

malak@malak.ca 2012-06-18 11:48:43 EDT

just did as previously stated (about 4.5 hours screen lock after screen saver / screen lock timed out on its own) and screen came back with desired screen resolution.

Will follow through again this evening when I get home again.

... and I spoke too soon. Out of curiosity, I went into Activities / Applications / System Tools / System Settings / Displays and whaddya know, the system decides "whoops, for whatever reason the hightest resolution available is 4:3 1024 x 768" and the screen automatically kicked down the resolution to 4:3 1024 x 768.

edit retag flag offensive close delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-06-20 06:02:33 +0000

Sith gravatar image

You're talking about a screensaver, so it can be a problem in that package. Anyway, try to use "xrandr" and see what does it say, if your resolution is available or not. If the 1280x1024 appears available do:

xrandr -s 1280x1024

Then go into the Xorg.conf and add this line into the Monitor section

Option "PreferredMode" "1280x1024"

I hope this helps!

edit flag offensive delete publish link more

Comments

The xrandr command confirms that 1280x1024 is not available. The issue initially seemed to be linked with the screensaver, but it seems to be with system settings and the system refusing to allow a resolution that I have used for years on the screen, and indeed before I "wake up" the system setting

malak ( 2012-06-20 11:23:10 +0000 )edit

Unfortunately the xrandr command confirms that 1280x1024 is not available.

malak ( 2012-06-20 11:23:11 +0000 )edit

Try to add your resolution to the xorg.conf. Example: Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480" then add you resolution:

Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

Sith ( 2012-06-20 12:08:31 +0000 )edit

If it doesn't work try to (if you are NOT using proprietary video-driver) to update the Kernel and X11 and then generate a new xorg.conf with "Xorg -configure" "cp /root/xorg.conf.new /etc/X11/xorg.conf"

Sith ( 2012-06-20 12:10:01 +0000 )edit

Last time the kernel upgraded a few days ago it ultimately had no effect. Adding the file /etc/X11/xorg.conf (there hadn't been one there before) causes the system to hang at bootup. Now I have to get into safe mode during bootup in order to remove the file.

malak ( 2012-06-20 16:15:15 +0000 )edit

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2012-06-20 02:54:00 +0000

Seen: 4,208 times

Last updated: Jun 20 '12