Ask Your Question
0

How do I use the Nemo File browser as default instead of Nautilus [closed]

asked 2013-02-03 20:14:34 -0600

Dinzy gravatar image

updated 2013-02-12 12:35:40 -0600

ryanlerch gravatar image

How do I remove the Default Nautilus File Browser in Fedora 18 (GNOME 3.6) and install Nemo File manager?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by hhlp
close date 2013-02-13 07:47:09.504602

Comments

Since the question has pretty much changed, would you be able to tweak the title and description to read something closer to "Changing default File Browser from Nautilus to Nemo" or similar?

ryanlerch gravatar imageryanlerch ( 2013-02-04 15:47:55 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2013-02-04 15:46:15 -0600

ryanlerch gravatar image

Nemo is a fork of Nautilus that keeps some of the features that were removed in Nautilus for the 3.6 release of GNOME. This post gives a good overview of some of the other reasons why people might want to change to Nemo over Nautilus -- http://cinnamon.linuxmint.com/?p=198

Installing the Nemo File Browser

Luckily, in Fedora 18, nemo is available in the Fedora repositories, so installing it is as simple as searching for nemo in Add / Remove Packages, or running:

yum install nemo

from the command line.

Once installed, you will be able to run nemo as a secondary file browser. Just search for nemo in the overview. It should show up as "Files" with a Folder icon, rather than the Filing Cabinet icon of Nautilus.

Using Nemo as Default File browser

Setting up GNOME to replace nautilus with nemo as the default file browser is a little bit more involved. First you need to start up the gnome menu editor, alacarte (yum install alacarte if you haven't previously installed it).

Once you have alacarte running, in the right hand pane, choose the Accessories category. The right hand pane should list two items with the Label "Files".

image description

Disable the nemo entry (the Files entry with the folder icon) by deselecting the checkbox beside the folder icon. Next, edit the nautilus entry (the one with the Filing Cabinet icon), by selecting it, and choosing properties.

In the Dialog that pops up, change the command from "nautilus %U" to "nemo %U"

image description

This should result in GNOME bringing up nemo rather than nautilus in most circumstances.

hope this helps, ryanlerch

edit flag offensive delete link more

Comments

after going over your initial question, i think your original problem was the new trend in GNOME apps. It is the one where the titlebar and close / minimize buttons are not shown when a window is maximised. I have done a seperate question for that now too: https://ask.fedoraproject.org/question/3936/how-do-i-stop-applications-hiding-their-titlebar

ryanlerch gravatar imageryanlerch ( 2013-02-12 13:17:30 -0600 )edit
0

answered 2013-02-05 02:09:43 -0600

This covers all possible settings regarding maximize, minimize buttons:

http://useful-linux-tips.blogspot.in/2013/02/enable-maximize-and-minimize-buttons.html

edit flag offensive delete link more

Comments

The user had changed his question a bit before you posted. The question is now how to install nemo rather than nautilus.

ryanlerch gravatar imageryanlerch ( 2013-02-05 05:29:57 -0600 )edit
0

answered 2013-02-04 00:52:33 -0600

Install "gnome-tweak-tool" package using "Software", yum, etc.

Launch "Tweak Tool", "Shell", "Arrangement of buttons on the titlebar", change to "All".

Done.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-02-03 20:14:34 -0600

Seen: 22,295 times

Last updated: Feb 12 '13