Ask Your Question
2

Failed to Load Kernel Modules F25

asked 2016-12-06 12:23:37 -0500

NeilRomig gravatar image

After a fresh install of Fedora 25 to my laptop upgraded, I am getting "Failed to start Load Kernel Modules" at bootup. This is also happening on my desktop PC which has been upgraded from F24. I have managed to catch an error from systemd status on the desktop which gives:

● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: active (exited) since Tue 2016-12-06 14:12:51 GMT; 38s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 717 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 717 (code=exited, status=1/FAILURE)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/systemd-modules-load.service

Dec 06 14:12:51 neilpc systemd[1]: Starting Load Kernel Modules...
Dec 06 14:12:51 neilpc systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FA
Dec 06 14:12:51 neilpc systemd[1]: Failed to start Load Kernel Modules.
Dec 06 14:12:51 neilpc systemd[1]: systemd-modules-load.service: Unit entered failed state.
Dec 06 14:12:51 neilpc systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.

While the laptop gives the same error on bootup but I have only got this from systemd so far:

    ● systemd-modules-load.service - Load Kernel Modules
       Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
       Active: active (exited) since Tue 2016-12-06 17:44:11 GMT; 1min 30s ago
         Docs: man:systemd-modules-load.service(8)
               man:modules-load.d(5)
      Process: 594 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS)
     Main PID: 594 (code=exited, status=0/SUCCESS)
        Tasks: 0 (limit: 4915)
       CGroup: /system.slice/systemd-modules-load.service

Dec 06 17:44:11 hp15ay167sa.home systemd[1]: Started Load Kernel Modules.

I did experience keyboard issues on the laptop initially but currently it is behaving well, so I am puzzled. What is causing this error - is it a kernel bug?

edit retag flag offensive close merge delete

Comments

I have the same configuration and am getting something similar (if not identical), though it scrolls by way too fast to photograph, is cleared when the video mode switches to graphic and the messages do not appear in dmesg.

wallyk gravatar imagewallyk ( 2016-12-06 13:20:18 -0500 )edit

I have found similar issues at fedoraforum and redhat bugzilla

NeilRomig gravatar imageNeilRomig ( 2016-12-06 13:22:16 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-12-06 13:43:39 -0500

Hi there, Check this link out!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-06 12:23:37 -0500

Seen: 8,103 times

Last updated: Dec 06 '16