Ask Your Question
2

Fedora 16 Grub2

asked 2011-11-09 16:38:32 -0600

SoumyaC gravatar image

After I upgraded to F16, I saw that the Grub2 splash image or the background is black. Ubuntu ships themes for Grub2 as far I know, but I didn't find any theme for Grub2 in Fedora. Any pointers on it or workarounds ?

Presently White on Black feels I m back in Red Hat 9 :(

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
2

answered 2011-11-13 09:38:16 -0600

ZenDark gravatar image

updated 2011-11-13 09:39:54 -0600

Found the solution in other question, and added the background bit:

Add the following to /etc/default/grub:

GRUB_GFXMODE=1280x960x16
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_BACKGROUND=/boot/verne.tga

Execute:

grub2-mkfont --output=/boot/grub2/unicode.pf2 /usr/share/fonts/dejavu/DejaVuSansMono.ttf

grub2-mkconfig -o /boot/grub2/grub.cfg

You can use any ttf font, any resolution supported by your monitor/card, and any image converted to tga. I used the verne.png background, since I love that background...

edit flag offensive delete link more

Comments

2

you don't need to create a tga for this you can use directly given the path in this case -> GRUB_BACKGROUND=/usr/share/backgrounds/verne/default/normalish/verne.png or wherever you have because the order is this FIRST search png then tga and next jpg|jpeg)... other different format are invalid...

hhlp gravatar imagehhlp ( 2011-11-13 15:48:07 -0600 )edit

it works. thanks a lot !!

SoumyaC gravatar imageSoumyaC ( 2011-11-13 20:11:38 -0600 )edit
0

answered 2011-12-31 09:23:52 -0600

Orion Caspar gravatar image

updated 2011-12-31 09:31:49 -0600

I want to add something here. In /etc/default/grub leave the entry GRUB_GFXMODE=1280x960x16 or whatever it is, intact. Don't edit this entry. Because, if you do this, then you need an image of size 1280x960 with 16-bit colour depth. In my system, the entry was simply GRUB_GFXMODE=1366x768. After a few experiments with the image resolution, I left that particular entry as it was. Instead, I choose an image and resized it into 1366x768. I didn't even changed the colour depth into 16-bit (I had to do it in splash.xpm.gz when legacy grub was used). Next step, I ran grub2-mkconfig -o /boot/grub2/grub.cfg, and init 6. Bingo! It worked! You can try it, and let me know the result.

edit flag offensive delete link more
0

answered 2011-11-10 21:15:09 -0600

Jackie gravatar image

you can put a image into /boot/grub2/;then modify the /etc/default/grub;use grub2-mkconfig to generate a new grub.cfg after that.

edit flag offensive delete link more

Comments

Did this tweak worked for you, this didn't work for me :(

SoumyaC gravatar imageSoumyaC ( 2011-11-11 06:22:13 -0600 )edit
0

answered 2011-11-09 21:55:38 -0600

FranciscoD_ gravatar image

I recall reading about this some place. It is so because the anaconda etc. teams didn't have enough time before the release to tweak things like the background image. (We switched from legacy grub to grub2 this release) Therefore, they decided to concentrate on getting it to work properly. From f17 onwards, you'll have a pretty grub. It maybe possible that they push an update for f16 too sometime. Here is a bug filed on this issue

edit flag offensive delete link more

Comments

Any workarounds @FranciscoD_ ?

SoumyaC gravatar imageSoumyaC ( 2011-11-11 06:22:34 -0600 )edit

Sorry, nothing that I'm aware of :/ You could CC yourself to the bug since it is where most chances of a workaround coming up are..

FranciscoD_ gravatar imageFranciscoD_ ( 2011-11-11 06:55:59 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-09 16:38:32 -0600

Seen: 10,651 times

Last updated: Dec 31 '11