Ask Your Question
1

pyspatialite install failed on F25

asked 2016-12-16 01:44:16 -0500

benjidad gravatar image

Success with qgis installation, however during qgis start, I have the following error:

Couldn't load plugin 'processing'

ImportError: No module named pyspatialite

following redhat bugzilla to run:

CFLAGS=-I/usr/include pip install pyspatialite

I got error as follow:

Command "/usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-QYLGKq/pyspatialite/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-qSGWo1-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-QYLGKq/pyspatialite/

Did anyone success installing qgis on Fedora 25?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-19 07:51:46 -0500

This solution requires allowing unofficial repositories, but it worked for me:

dnf copr enable dani/QGIS-latest-stable
dnf install qgis qgis-python

taken from the here. Only qgis and qgis-python were taken from the copr repository. All other dependencies were downloaded from the official Fedora 25 repositories.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-16 01:44:16 -0500

Seen: 308 times

Last updated: Dec 19 '16