Ask Your Question
4

How do I disable user list in GDM

asked 2013-01-17 07:12:38 -0500

0nickyet gravatar image

updated 2013-02-19 14:05:00 -0500

mether gravatar image

Hi, In former times it was possible to disable the user list of GDM by setting /apps/gdm/simple-greeter/disableuserlist to 'true' with the help of gconf-editor. The dconf-editor doesn't offer this option. How do I disable the user list in GDM 3.6.2?

edit retag flag offensive close merge delete

Comments

ssieb gravatar imagessieb ( 2015-02-19 19:00:35 -0500 )edit

Link for the Gnome documentation is now broken (as of Nov 2015).

David Ramirez gravatar imageDavid Ramirez ( 2015-11-19 13:13:39 -0500 )edit

Current document is now at https://help.gnome.org/admin/system-a...

ssieb gravatar imagessieb ( 2016-05-06 15:29:42 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
7

answered 2013-01-18 03:50:36 -0500

domg472 gravatar image

updated 2013-01-18 03:51:14 -0500

cat > /etc/dconf/db/gdm.d/01-mysettings <<EOF
[org/gnome/login-screen]
banner-message-enable=true
banner-message-text='WARNING!!! You have accessed a private network.\nUNAUTHORIZED ACCESS IS PROHIBITED BY LAW\nViolators may be prosecuted to the full extend of the law.\nYour access to this network may be monitored and recorded for quality\nassurance, security, performance, and maintenance purposes.' 
disable-restart-buttons=true
disable-user-list=true
EOF

rm /etc/dconf/db/gdm
dconf update
edit flag offensive delete link more

Comments

I can't edit the answer, so I'll add it here.

There's one more step needed to make this work. Create a file called /etc/dconf/profile/gdm and put the following in it:

user-db:user

system-db:gdm

ssieb gravatar imagessieb ( 2015-02-19 18:56:53 -0500 )edit

Recompiling the /etc/dconf/db/gdm file such as: dconf compile gdm gdm.d recreates the file, that otherwise is left untouched by dconf update if it already exists. The solution above works around this by deleting it. This may be helful if you are scripting this procedure. Worked for me with Fedora 23.

David Ramirez gravatar imageDavid Ramirez ( 2015-11-19 13:11:26 -0500 )edit
0

answered 2013-02-18 01:17:05 -0500

plembo gravatar image

Shouldn't the title here be changed to "UNSOLVED"?

edit flag offensive delete link more
0

answered 2013-11-04 10:50:13 -0500

jamest gravatar image

Has anyone had any success getting the warning banner to work in Fedora 20 Beta using the file (/etc/dconf/db/gdm.d/01-mysettings) method ? I am able to disable the user list, but cannot seem to get the banner text to display.

edit flag offensive delete link more
0

answered 2013-01-17 15:07:00 -0500

ThomasMcA gravatar image

On my Fedora XFCE spin, I was able to remove users from the login screen by changing their login shell to /sbin/nologin. (It is a property of the user account in Users & Groups.)

edit flag offensive delete link more
0

answered 2013-01-17 07:25:13 -0500

ztank1013 gravatar image

updated 2013-01-17 07:37:59 -0500

UPDATE:
apparently this isn't working at the moment. I will dig to find how and update this answer as soon as I get a better one!

To view the current status run

gsettings get org.gnome.login-screen disable-user-list

and the output should be "false".

To disable run the following command

gsettings set org.gnome.login-screen disable-user-list true

Then logout and see if it works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-01-17 07:12:38 -0500

Seen: 46,988 times

Last updated: Apr 18 '14