English
Ask Your Question
3

Why doesn't wayland / gnome detect my wacom tablet as a tablet?

asked 2016-12-20 11:27:20 +0000

rio gravatar image

updated 2016-12-20 12:17:53 +0000

hhlp gravatar image

I've upgraded to Fedora 25 last week and haven't been able to get gnome to detect my pen tablet properly. The Tablet preference panel stays empty. Instead I get not one but two mouse cursors! Which I think is awesome and not a problem if it worked as expected. For example right mouse clicks on the tablet will only sometimes pop up an menu underneath the pen tablet's cursor but most of the time it will pop up underneath the mouse's cursor.

Also quite some apps do not accept the tablet's mouse as input, firefox and chrome for example don't but the gnome file browser does. However the context menu doesn't work in that case. Because gnome doesn't detect the tablet properly I can't configure it to for example switch monitors with a button on the pad, big workflow downer.

I've already tried to disable wayland using /etc/gdm/custom.conf and setting WaylandEnable=false which gets me my old behaviour back with the single cursor and all program's accepting input but monitor switching is broken there. However it makes the desktop a bit unstable. Gnome crashes at random 1 to 2 hour intervals. Even without dual monitors.

If somebody could help me debug this, point me in the right direction or even has a sollution I'd be very very grateful!

I'm running an older Dell XPS 13 Developer Edition. Kernel version: 4.8.14-300.fc25.x86_64

journalctl output:

```

usb 3-1.4.1: new full-speed USB device number 7 using xhci_hcd
usb 3-1.4.1: New USB device found, idVendor=056a, idProduct=0065
usb 3-1.4.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 3-1.4.1: Product: MTE-450
usb 3-1.4.1: Manufacturer: Wacom Co.,Ltd.
input: Wacom Bamboo Pen as /devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1.4/3-1.4.1/3-1.4.1:1.0/0003:056A:0065.0003/input/input10
input: Wacom Bamboo Pad as /devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1.4/3-1.4.1/3-1.4.1:1.0/0003:056A:0065.0003/input/input12
wacom 0003:056A:0065.0003: hidraw2: USB HID v1.00 Mouse [Wacom Co.,Ltd. MTE-450] on usb-0000:00:14.0-1.4.1/input0

```

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2017-02-01 03:39:19 +0000

whot gravatar image

see my answer here: https://ask.fedoraproject.org/en/ques...

if you have two independent cursors, you're running under Wayland. Select GNOME on Xorg to switch back to X. At this point tablet support is unfortunately still a bit incomplete. GTK supports it, but not much else does.

edit flag offensive delete link more
0

answered 2017-01-30 13:26:46 +0000

rio gravatar image

updated 2017-01-30 13:28:21 +0000

Here is a log of X when it crashed. just fyi.

[ 10616.174] (--) Log file renamed from "/home/rio/.local/share/xorg/Xorg.pid-4443.log" to "/home/rio/.local/share/xorg/Xorg.0.log"
[ 10616.179] 
X.Org X Server 1.19.1
Release Date: 2017-01-11
[ 10616.179] X Protocol Version 11, Revision 0
[ 10616.179] Build Operating System:  4.9.3-200.fc25.x86_64 
[ 10616.179] Current Operating System: Linux ravage 4.9.5-200.fc25.x86_64 #1 SMP Fri Jan 20 12:24:16 UTC 2017 x86_64
[ 10616.179] Kernel command line: BOOT_IMAGE=/vmlinuz-4.9.5-200.fc25.x86_64 root=/dev/mapper/fedora_ravage-root ro rd.lvm.lv=fedora_ravage/root rd.luks.uuid=luks-57107b1c-35f0-4b5a-9126-2c26e085c486 rd.lvm.lv=fedora_ravage/swap rhgb quiet LANG=en_US.UTF-8
[ 10616.179] Build Date: 16 January 2017  04:11:55PM
[ 10616.179] Build ID: xorg-x11-server 1.19.1-2.fc25 
[ 10616.179] Current version of pixman: 0.34.0
[ 10616.179]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[ 10616.179] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 10616.179] (==) Log file: "/home/rio/.local/share/xorg/Xorg.0.log", Time: Mon Jan 30 13:20:34 2017
[ 10616.182] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 10616.182] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 10616.184] (==) No Layout section.  Using the first Screen section.
[ 10616.184] (==) No screen section available. Using defaults.
[ 10616.184] (**) |-->Screen "Default Screen Section" (0)
[ 10616.184] (**) |   |-->Monitor "<default monitor>"
[ 10616.184] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[ 10616.184] (==) Automatically adding devices
[ 10616.184] (==) Automatically enabling devices
[ 10616.184] (==) Automatically adding GPU devices
[ 10616.184] (==) Automatically binding GPU devices
[ 10616.184] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 10616.184] (==) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins
[ 10616.184] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 10616.184] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 10616.184] (II) Loader magic: 0x825e00
[ 10616.184] (II) Module ABI versions:
[ 10616.184]    X.Org ANSI C Emulation: 0.4
[ 10616.184]    X.Org Video Driver: 23.0
[ 10616.184]    X.Org XInput driver : 24.1
[ 10616.184]    X.Org Server Extension : 10.0
[ 10616.186] (++) using VT number 2

[ 10616.189] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_35
[ 10616.190] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 10616.191] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 12 paused 0
[ 10616.192] (--) PCI:*(0:0:2:0) 8086:0166:1028:058b rev 9, Mem @ 0xd0000000/4194304, 0xc0000000/268435456, I/O @ 0x00002000/64, BIOS @ 0x????????/65536
[ 10616.192] (II) LoadModule: "glx"
[ 10616.193] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 10616.195] (II) Module glx: vendor="X.Org Foundation"
[ 10616.195]    compiled for 1 ...
(more)
edit flag offensive delete link more
0

answered 2016-12-23 06:54:16 +0000

corlatemanuel gravatar image

It's something related to wayland, as a work around use ,,GNOME on Xorg" option when logging in from the cog that is next to the Log in button. This should work. It also works on Plasma because the desktop uses Xorg.

edit flag offensive delete link more

Comments

Thanks, I've tried running Gnome on Xorg but after a couple of hours (2-3) It simply crashes and dumps me back to GDM.

rio ( 2017-01-30 12:23:05 +0000 )edit
0

answered 2016-12-20 16:45:29 +0000

neverknew gravatar image

I use a Wacom Bamboo Fun tablet and just updated to Fedora 25 (same kernel version you have). I'm using KDE/Plasma instead of Gnome, but the tablet & stylus seem to be working fine.

It's possible you need to re-install the Wacom definitions.

edit flag offensive delete link more

Comments

On plasma it also works fine but that's because of it running in Xorg i guess. Xorg just segfaults after a while. It never did that on Fedora 24.

rio ( 2017-01-30 13:24:17 +0000 )edit

the crash is probably https://bugzilla.redhat.com/show_bug....

whot ( 2017-02-01 03:38:02 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2016-12-20 11:27:20 +0000

Seen: 2,794 times

Last updated: Feb 01