English
Ask Your Question
1

How to add a custom resolution to Weyland Fedora 25?

asked 2017-01-08 13:53:40 +0000

bcmalloyman gravatar image

updated 2017-01-08 23:35:40 +0000

leigh123linux gravatar image

I usually use the commands below in linux to add a custom resoltion so my nuc 4k@60hz DP to hdmi adptor will give me full 60hz glory but cant get it working in fedora 25, any help would be appreciated.

xrandr --newmode "3840x2160_59.95" 533.6 3840 3982 4027 4064 2160 2170 2180 2190 +hsync +vsync
xrandr --addmode DP1 "3840x2160_59.95"
xrandr --output DP1 --mode "3840x2160_59.95"

Here are the results of my attempt to get this working in Fedora 25

xrandr: cannot find output "DP1"
warning: output DP1 not found; ignoring
[mike@localhost ~]$ xrandr
Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 8192 x 8192
XWAYLAND0 connected 3840x2160+0+0 950mm x 540mm
   3840x2160     29.96*+
  3840x2160_59.95 (0x27c) 533.600MHz +HSync +VSync
        h: width  3840 start 3982 end 4027 total 4064 skew    0 clock 131.30KHz
        v: height 2160 start 2170 end 2180 total 2190           clock  59.95Hz
[mike@localhost ~]$ xrandr --output XWAYLAND0 --mode "3840x2160_59.95"
xrandr: cannot find mode 3840x2160_59.95
[mike@localhost ~]$ xrandr --addmode XWAYLAND0 "3840x2160_59.95"
[mike@localhost ~]$ xrandr --output XWAYLAND0 --mode "3840x2160_59.95"
xrandr: Configure crtc 0 failed
[mike@localhost ~]$ xrandr --verbose
Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 8192 x 8192
XWAYLAND0 connected (normal)
    Identifier: 0x21
    Timestamp:  470836
    Subpixel:   unknown
    Clones:    
    CRTCs:      0
    Transform:  1.000000 0.000000 0.000000
                0.000000 1.000000 0.000000
                0.000000 0.000000 1.000000
               filter: 
  3840x2160 (0x22) 338.500MHz -HSync +VSync +preferred
        h: width  3840 start 4080 end 4488 total 5136 skew    0 clock  65.91KHz
        v: height 2160 start 2163 end 2168 total 2200           clock  29.96Hz
  3840x2160_59.95 (0x27c) 533.600MHz +HSync +VSync
        h: width  3840 start 3982 end 4027 total 4064 skew    0 clock 131.30KHz
        v: height 2160 start 2170 end 2180 total 2190           clock  59.95Hz
[mike@localhost ~]$ xrandr --crtc XWAYLAND0 --output XWAYLAND0 --mode "3840x2160_59.95"
xrandr: --crtc must be used after --output
Try 'xrandr --help' for more information.
[mike@localhost ~]$ xrandr --output XWAYLAND0 --crtc XWAYLAND0 --mode "3840x2160_59.95"
xrandr: invalid name 'XWAYLAND0'
Try 'xrandr --help' for more information.
[mike@localhost ~]$ xrandr --output XWAYLAND0 --crtc CRT0 --mode "3840x2160_59.95"
xrandr: invalid name 'CRT0'
Try 'xrandr --help' for more information.
[mike@localhost ~]$ xrandr --output XWAYLAND0 --crtc CRT1 --mode "3840x2160_59.95"
xrandr: invalid name 'CRT1'
[mike@localhost ~]$ xrandr --output XWAYLAND0 --mode "3840x2160_59.95"
xrandr: Configure crtc 0 failed
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2017-01-11 12:16:35 +0000

I had the same problem and the following solution seems to be working for now.

First, you'll need to clone edid-generator. Then you can pass it your modeline (with the same arguments you gave xrandr --newmode:

$ ./modeline2edid - <<< 'Modeline "3840x2160" 533.6 3840 3982 4027 4064 2160 2170 2180 2190 +hsync +vsy'

Then generate the edid binary with make. Then following this on archwiki, you can copy the generated 3840x2160.bin file in /usr/lib/firmware/edid. Then restart and edit the kernel command line (pressing e in grub) to add drm_kms_helper.edid_firmware=edid/3840x2160.bin.

If everything worked correctly, your screen should have the desired resolution once the boot is finished.

To make it permanent

Add GRUB_CMDLINE_LINUX_DEFAULT="drm_kms_helper.edid_firmware=edid/3840x2160.bin" to /etc/default/grub and regenerate the grub configuration:

# grub2-mkconfig -o /boot/grub2/grub.cfg

That's assuming your machine uses grub on a BIOS system, see this for EFI and this for other bootloaders.

edit flag offensive delete link more

Comments

Worked great but unfortunately I lost my DP sound output and gained a better resolution

bcmalloyman ( 2017-01-22 09:40:50 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2017-01-08 13:53:40 +0000

Seen: 377 times

Last updated: Jan 11