Ask Your Question

Revision history [back]

Fedora 25, USB tethering not stable.

I am using my cellphone as a Wifi adapter but I got problem. The fedora is 25. When I turn on usb tethering from cell phone (model: LG G4), the Fedora get "USB Ethernet" and works perfectly, I can access internet normally.

I check with ifconfig, I see the cellphone interface with correct IP address like 192.168.42.73. (enp0s20f0u1 is my cellphone interface) $ifconfig enp0s20f0u1: flags=4163<up,broadcast,running,multicast> mtu 1500 inet 192.168.42.73 netmask 255.255.255.0 broadcast 192.168.42.255 inet6 fe80::942f:caff:fe19:b091 prefixlen 64 scopeid 0x20<link> ether 96:2f:ca:19:b0:91 txqueuelen 1000 (Ethernet) RX packets 46 bytes 1961 (1.9 KiB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 205 bytes 34218 (33.4 KiB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

After around 10 to 20 seconds, the "USB Ethernet" disappear and I got "Mobile network" from the "Network" window, and no internet anymore. I tried to configure this "Mobile" and get IP immediately, but I still don't have internet access. And I checked with ifconfig, the cellphone interface has no IP address.

$ifconfig enp0s20f0u1: flags=4163<up,broadcast,running,multicast> mtu 1500 ether 96:2f:ca:19:b0:91 txqueuelen 1000 (Ethernet) RX packets 7 bytes 560 (560.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 0 bytes 0 (0.0 B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

How do I keep the USB Enthernet to get internet always working? Any clue, I appreciate.

click to hide/show revision 2
No.2 Revision

Fedora 25, USB tethering not stable.

I am using my cellphone as a Wifi adapter but I got problem. The fedora is 25. When I turn on usb tethering from cell phone (model: LG G4), the Fedora get "USB Ethernet" and works perfectly, I can access internet normally.

I check with ifconfig, I see the cellphone interface with correct IP address like 192.168.42.73. (enp0s20f0u1 is my cellphone interface) $ifconfig interface)

$ifconfig

enp0s20f0u1: flags=4163<up,broadcast,running,multicast> flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.42.73  netmask 255.255.255.0  broadcast 192.168.42.255
        inet6 fe80::942f:caff:fe19:b091  prefixlen 64  scopeid 0x20<link>
        ether 96:2f:ca:19:b0:91  txqueuelen 1000  (Ethernet)
        RX packets 46  bytes 1961 (1.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 205  bytes 34218 (33.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

0

After around 10 to 20 seconds, the "USB Ethernet" disappear and I got "Mobile network" from the "Network" window, and no internet anymore. I tried to configure this "Mobile" and get IP immediately, but I still don't have internet access. And I checked with ifconfig, the cellphone interface has no IP address.

$ifconfig $ifconfig

enp0s20f0u1: flags=4163<up,broadcast,running,multicast> flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 96:2f:ca:19:b0:91  txqueuelen 1000  (Ethernet)
        RX packets 7  bytes 560 (560.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

0

How do I keep the USB Enthernet to get internet always working? Any clue, I appreciate.

Fedora 25, USB tethering not stable.

I am using my cellphone as a Wifi adapter but I got problem. The fedora is 25. When I turn on usb tethering from cell phone (model: LG G4), the Fedora get "USB Ethernet" and works perfectly, I can access internet normally.

I check with ifconfig, I see the cellphone interface with correct IP address like 192.168.42.73. (enp0s20f0u1 is my cellphone interface)

$ifconfig

enp0s20f0u1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.42.73  netmask 255.255.255.0  broadcast 192.168.42.255
        inet6 fe80::942f:caff:fe19:b091  prefixlen 64  scopeid 0x20<link>
        ether 96:2f:ca:19:b0:91  txqueuelen 1000  (Ethernet)
        RX packets 46  bytes 1961 (1.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 205  bytes 34218 (33.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

After around 10 to 20 seconds, seconds, the "USB Ethernet" disappear and I got "Mobile network" from the "Network" window, and no internet anymore. I tried to configure this "Mobile" and get IP immediately, but I still don't have internet access. And I checked with ifconfig, the cellphone interface has no IP address.

$ifconfig

enp0s20f0u1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 96:2f:ca:19:b0:91  txqueuelen 1000  (Ethernet)
        RX packets 7  bytes 560 (560.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

How do I keep the USB Enthernet to get internet always working? Any clue, I appreciate.