Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Upgrading from Fedora 28 to Fedora 29 errors

dnf system-upgrade download --refresh --releasever=29 --allowerasing --best Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y Failed to synchronize cache for repo 'updates-testing', disabling. Last metadata expiration check: 0:00:00 ago on Sat 08 Dec 2018 04:03:16 PM AEDT. Error: Problem 1: package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires /usr/bin/python3, but none of the providers can be installed - package python3-3.7.1-4.fc29.i686 requires libpython3.7m.so.1.0, but none of the providers can be installed - package python3-3.7.1-4.fc29.x86_64 requires libpython3.7m.so.1.0()(64bit), but none of the providers can be installed - cannot install the best update candidate for package dnf-2.7.5-12.fc28.noarch - python3-3.6.7-2.fc28.x86_64 does not belong to a distupgrade repository - nothing provides libgdbm.so.6 needed by python3-libs-3.7.1-4.fc29.i686 - nothing provides libgdbm.so.6()(64bit) needed by python3-libs-3.7.1-4.fc29.x86_64 Problem 2: problem with installed package dnf-2.7.5-12.fc28.noarch - package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires python3-rpm >= 4.14.0, but none of the providers can be installed - package python3-rpm-4.14.2.1-2.fc29.x86_64 requires rpm-libs(x86-64) = 4.14.2.1-2.fc29, but none of the providers can be installed - python3-rpm-4.14.2.1-2.fc28.x86_64 does not belong to a distupgrade repository - dnf-2.7.5-12.fc28.noarch does not belong to a distupgrade repository - nothing provides libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) needed by rpm-libs-4.14.2.1-2.fc29.x86_64


Any guidance please?

click to hide/show revision 2
None

updated 2018-12-08 04:09:16 -0500

hhlp gravatar image

Upgrading from Fedora 28 to Fedora 29 errors

dnf system-upgrade download --refresh --releasever=29 --allowerasing --best Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y Failed to synchronize cache for repo 'updates-testing', disabling. Last metadata expiration check: 0:00:00 ago on Sat 08 Dec 2018 04:03:16 PM AEDT. Error: Problem 1: package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires /usr/bin/python3, but none of the providers can be installed - package python3-3.7.1-4.fc29.i686 requires libpython3.7m.so.1.0, but none of the providers can be installed - package python3-3.7.1-4.fc29.x86_64 requires libpython3.7m.so.1.0()(64bit), but none of the providers can be installed - cannot install the best update candidate for package dnf-2.7.5-12.fc28.noarch - python3-3.6.7-2.fc28.x86_64 does not belong to a distupgrade repository - nothing provides libgdbm.so.6 needed by python3-libs-3.7.1-4.fc29.i686 - nothing provides libgdbm.so.6()(64bit) needed by python3-libs-3.7.1-4.fc29.x86_64 Problem 2: problem with installed package dnf-2.7.5-12.fc28.noarch - package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires python3-rpm >= 4.14.0, but none of the providers can be installed - package python3-rpm-4.14.2.1-2.fc29.x86_64 requires rpm-libs(x86-64) = 4.14.2.1-2.fc29, but none of the providers can be installed - python3-rpm-4.14.2.1-2.fc28.x86_64 does not belong to a distupgrade repository - dnf-2.7.5-12.fc28.noarch does not belong to a distupgrade repository - nothing provides libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) needed by rpm-libs-4.14.2.1-2.fc29.x86_64


Any guidance please?

click to hide/show revision 3
None

updated 2018-12-08 04:09:30 -0500

hhlp gravatar image

Upgrading from Fedora 28 to Fedora 29 errors

dnf system-upgrade download --refresh --releasever=29 --allowerasing --best Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y Failed to synchronize cache for repo 'updates-testing', disabling. Last metadata expiration check: 0:00:00 ago on Sat 08 Dec 2018 04:03:16 PM AEDT. Error: Problem 1: package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires /usr/bin/python3, but none of the providers can be installed - package python3-3.7.1-4.fc29.i686 requires libpython3.7m.so.1.0, but none of the providers can be installed - package python3-3.7.1-4.fc29.x86_64 requires libpython3.7m.so.1.0()(64bit), but none of the providers can be installed - cannot install the best update candidate for package dnf-2.7.5-12.fc28.noarch - python3-3.6.7-2.fc28.x86_64 does not belong to a distupgrade repository - nothing provides libgdbm.so.6 needed by python3-libs-3.7.1-4.fc29.i686 - nothing provides libgdbm.so.6()(64bit) needed by python3-libs-3.7.1-4.fc29.x86_64 Problem 2: problem with installed package dnf-2.7.5-12.fc28.noarch - package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires python3-rpm >= 4.14.0, but none of the providers can be installed - package python3-rpm-4.14.2.1-2.fc29.x86_64 requires rpm-libs(x86-64) = 4.14.2.1-2.fc29, but none of the providers can be installed - python3-rpm-4.14.2.1-2.fc28.x86_64 does not belong to a distupgrade repository - dnf-2.7.5-12.fc28.noarch does not belong to a distupgrade repository - nothing provides libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) needed by rpm-libs-4.14.2.1-2.fc29.x86_64


Any guidance please?

click to hide/show revision 4
None

updated 2018-12-08 04:10:03 -0500

hhlp gravatar image

Upgrading from Fedora 28 to Fedora 29 errors

dnf system-upgrade download --refresh --releasever=29 --allowerasing --best Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y Failed to synchronize cache for repo 'updates-testing', disabling. Last metadata expiration check: 0:00:00 ago on Sat 08 Dec 2018 04:03:16 PM AEDT. Error: Problem 1: package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires /usr/bin/python3, but none of the providers can be installed - package python3-3.7.1-4.fc29.i686 requires libpython3.7m.so.1.0, but none of the providers can be installed - package python3-3.7.1-4.fc29.x86_64 requires libpython3.7m.so.1.0()(64bit), but none of the providers can be installed - cannot install the best update candidate for package dnf-2.7.5-12.fc28.noarch - python3-3.6.7-2.fc28.x86_64 does not belong to a distupgrade repository - nothing provides libgdbm.so.6 needed by python3-libs-3.7.1-4.fc29.i686 - nothing provides libgdbm.so.6()(64bit) needed by python3-libs-3.7.1-4.fc29.x86_64 Problem 2: problem with installed package dnf-2.7.5-12.fc28.noarch - package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires python3-rpm >= 4.14.0, but none of the providers can be installed - package python3-rpm-4.14.2.1-2.fc29.x86_64 requires rpm-libs(x86-64) = 4.14.2.1-2.fc29, but none of the providers can be installed - python3-rpm-4.14.2.1-2.fc28.x86_64 does not belong to a distupgrade repository - dnf-2.7.5-12.fc28.noarch does not belong to a distupgrade repository - nothing provides libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) needed by rpm-libs-4.14.2.1-2.fc29.x86_64


Any guidance please?