English
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How can one upgrade from Fedora 18 to 19?

I know that 17-18 began the fedup only usage, but one of the accepted features is to keep preupgrade. Fedora 19 Alpha has been released. The fedup page details 17-18. It is specific to 18. I tried changing the version for the release server for fedup-cli, but to know avail. "Could not parse metalink https//mirrors.fedoraproject.org/metalink?repo=fedora-19&arch=x8664 error was No repomd file"

I manually edited /etc/yum.repos.d/{fedora.repo,fedora-updates.repo} to point at https//dl.fedoraproject.org/pub/fedora/linux/updates/19/x8664/. This bypassed that previous error to get "if set(updates) != set(pkgs): TypeError: 'NoneType' object is not iterable"

Also, fedup is at 0.7.1 in 18, but is purported to be fedup-0.7.2-1.fc17 (http//fedoraproject.org/wiki/FedUp#HowCanIUpgradeMySystemwithFedUp.3F).

How can one upgrade from Fedora 18 to 19?

I know that 17-18 began the fedup only usage, but one of the accepted features is to keep preupgrade. Fedora 19 Alpha pre-Alpha has been released. branched. The fedup page details 17-18. It is specific to 18. I tried changing the version for the release server for fedup-cli, but to know no avail. "Could not parse metalink https//mirrors.fedoraproject.org/metalink?repo=fedora-19&arch=x8664 error was No repomd file"

I manually edited /etc/yum.repos.d/{fedora.repo,fedora-updates.repo} to point at https//dl.fedoraproject.org/pub/fedora/linux/updates/19/x8664/. This bypassed that previous error to get "if set(updates) != set(pkgs): TypeError: 'NoneType' object is not iterable"

Also, fedup is at 0.7.1 in 18, but is purported to be fedup-0.7.2-1.fc17 (http//fedoraproject.org/wiki/FedUp#HowCanIUpgradeMySystemwithFedUp.3F).

click to hide/show revision 3
retagged, reformatted the question a bit

How can one upgrade from Fedora 18 to 19?

I know that 17-18 began the fedup only usage, but one of the accepted features is to keep preupgrade. Fedora 19 pre-Alpha has been branched. The fedup page details 17-18. It is specific to 18. I tried changing the version for the release server for fedup-cli, but to no avail. "Could avail.

Could not parse metalink https//mirrors.fedoraproject.org/metalink?repo=fedora-19&arch=x8664 https://mirrors.fedoraproject.org/metalink?repo=fedora-19&arch=x86_64 error was  No repomd file"

file

I manually edited /etc/yum.repos.d/{fedora.repo,fedora-updates.repo} /etc/yum.repos.d/{fedora.repo,fedora-updates.repo} to point at https//dl.fedoraproject.org/pub/fedora/linux/updates/19/x8664/. https://dl.fedoraproject.org/pub/fedora/linux/updates/19/x86_64/. This bypassed that previous error to get "if set(updates) != set(pkgs): set(pkgs):

TypeError: 'NoneType' object is not iterable"

iterable"

Also, fedup is at 0.7.1 in 18, but is purported to be fedup-0.7.2-1.fc17 (http//fedoraproject.org/wiki/FedUp#HowCanIUpgradeMySystemwithFedUp.3F).fedup-0.7.2-1.fc17

Fedup documentation.