Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

CPU performance slow while on battery in Fedora 18

I updated from Fedora 17 to Fedora 18 a few days ago using fedup. The transition seemed to go fine and after a few "yum updates" all is well, except...

If my laptop is not plugged into the wall, the CPU performance is much worse. I use my laptop for compilation and running CPU intensive programs while travelling. Under Fedora 17, the performance was pretty much the same with our without wall power.

I read the Fedora 18 Power Management Guide (which seems to be a bit out-of-date in that I have no /etc/tuned-profile despite having the necessary packaged installed). I changed the active profile to balanced and also tried throughput-performance. Eventually, I turned it off. None of these things seem to have an effect.

I can run a CPU-intensive job. It will speed up and slow down as I plug in and unplug the power adaptor. I know under Fedora 17 this didn't happen (or if it did, it was a much much less noticable effect).

Is there another setting I should be looking at?

CPU performance slow while on battery in Fedora 18

I updated from Fedora 17 to Fedora 18 a few days ago using fedup. The transition seemed to go fine and after a few "yum updates" all is well, except...

If my laptop is not plugged into the wall, the CPU performance is much worse. I use my laptop for compilation and running CPU intensive programs while travelling. Under Fedora 17, the performance was pretty much the same with our without wall power.

I read the Fedora 18 Power Management Guide (which seems to be a bit out-of-date in that I have no /etc/tuned-profile despite having the necessary packaged installed). I changed the active profile to balanced and also tried throughput-performance. Eventually, I turned it off. None of these things seem to have an effect.

I can run a CPU-intensive job. It will speed up and slow down as I plug in and unplug the power adaptor. I know under Fedora 17 this didn't happen (or if it did, it was a much much less noticable effect).

Is there another setting I should be looking at?

UPDATE: I tried the governor as suggested below and even turned it off. That didn't seem to change anything (it was on regardless of the power state). As noted, cpupower told me that the frequency was limited to between 800-1000MHz (although it knew the processors could go to 2.4GHz), so I changed that. It now will hit 2.4 GHz on some compute jobs. However, it still feels slower (but I have no quantifiable data).

Additionally, it seems to take more power during sleep (I think even before I made these changes). Again, I don't have hard data. If anyone has other experiences, I'd like to hear them. The laptop is a Thinkpad W520.