Haz tu Pregunta
1

Error al actualizar con DNF en Fedora 22

preguntado 2015-07-22 20:01:04 -0500

Imagen Gravatar de jesusKDE

Hola, tengo un error y no se como solucionarlo, soy un admirador del Software libre y ya tiene rato que me pasé a Linux, elegí la distro Fedora. Ahora tengo la última versión que es la 22 y llevo varios dias que tengo este error al actualizar el sistema con dnf. Al darle la instrucción: dnf -y update, el gestor carga y llega como al 80% de ahí manda este error:

advertencia:/var/cache/dnf/x86_64/22/google-chrome/packages/google-chrome-stable-44.0.2403.89-1.x86_64.rpm: EncabezadoV4 DSA/SHA1 Signature, ID de clave 7fac5991: NOKEY Error: No se ha instalado la llave pública de google-chrome-stable-44.0.2403.89-1.x86_64.rpm

Como ya dije tengo tiempo con este SO, solo que no soy muy experto en ello pues solo hago las operaciones comunes y por lo tanto no soy experto; todavía me falta de aŕender algo.

Se los agradezco mucho!!!!

edit re-etiquetar marcar como ofensivo cerrar fusionar delete

Comments

cabe destacar que instalé google con un instalador RPM y no instalé ningún repositorio ya que investigué que fedora tiene algunos problemillas de los repos oficiales de dicho navegador.

Imagen Gravatar de jesusKDE jesusKDE ( 2015-07-22 20:03:11 -0500 )edit

Aqui la respuesta.

sudo rpm --import https://dl-ssl.google.com/linux/linux_signing_key.pub
Imagen Gravatar de davidva davidva ( 2015-07-24 02:36:26 -0500 )edit

1 Responder

Ordenar por » viejos nuevas más votado
1

respondido 2015-07-23 01:27:39 -0500

Imagen Gravatar de Ferm

updated 2015-07-23 01:46:18 -0500

Hola: efectivamente, necesitas añadir la clave pública de google chrome. Lo que podrías hacer sin instalar nada de clave pública es desinstalar y volver a instalar chrome después de haber actualizado, o acceder al archivo en la ruta /etc/yum.repos.d y modificar o crear un archivo con el nombre de google-chrome.repo y en la línea que dice gpgcheck=1 lo modificas a gpgcheck=0 esto le indicará al sistema que no verifique la clave pública.

Te paso el link de mi blog para mayor información http://linuxgx.blogspot.mx/2015/04/re... . Pero lo que tienes que hacer es en caso de que no tengas el repositorio oficial, entonces agregarlo, para eso ve a la ruta /etc/yum.repos.d debería de estar un archivo con el nombre de google-chrome.repo, en caso de que no esté, crea uno con el comando sudo gedit google-chrome.repo dentro de este archivo agrega lo siguiente, solo usa uno de los dos:

[google-chrome] name=google-chrome baseurl=http://dl.google.com/linux/chrome/rpm/stable/x86_64 enabled=1 gpgcheck=1

en caso de desactivar la clave usa esta otra configuración:

[google-chrome] name=google-chrome baseurl=http://dl.google.com/linux/chrome/rpm/stable/x86_64 enabled=1 gpgcheck=0

Espero haberte ayudado, en caso de que no funcione me avisas para corroborar la solución. Buen día. Aquí hay un link oficial de google chrome para agregar su llave pública http://www.google.com/linuxrepositories/

edit marcar como ofensivo delete enlace mas

Comments

gracias me ayudaste mucho, por sierto ya chequé tu blog y está muy insteresante

Imagen Gravatar de jesusKDE jesusKDE ( 2015-07-23 18:01:29 -0500 )edit

Tu Respuesta

Comience a publicar de forma anónima - su entrada será publicada después de iniciar sesión o crear una nueva cuenta.

Agregar Respuesta

Herramientas de Preguntas

1 seguidor

Estadisticas

Preguntado: 2015-07-22 20:01:04 -0500

Visto: 3,169 veces

Ultima actualización: Jul 23 '15