Haz tu Pregunta
0

¿Cómo solucionar este error? [Solucionado] [cerrado]

preguntado 2015-09-18 10:06:38 -0600

Imagen Gravatar de Ferm

updated 2015-10-03 19:07:38 -0600

Estoy intentando actualizar utilizando sudo dnf -y update y me arroja este error

Traceback (most recent call last): File "/bin/dnf", line 36, in <module> main.user_main(sys.argv[1:], exit_code=True) File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 198, in user_main errcode = main(args) File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main return _main(base, args) File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 117, in _main cli.configure(map(ucd, args)) File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1007, in configure self.optparser.usage = self.optparser.get_usage() File "/usr/lib/python2.7/site-packages/dnf/cli/option_parser.py", line 273, in get_usage usage += "%-25s %s\n" % (name, summary) UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)

edit re-etiquetar marcar como ofensivo reabrir fusionar delete

Cerrada por la siguiente razón la pregunta ha sido respondida, la respuesta correcta ha sido aceptada por Ferm
fecha de cierre 2015-09-24 20:06:57.544401

3 Respuestas

Ordenar por » viejos nuevas más votado
1

respondido 2015-09-24 17:33:52 -0600

Hola. El problema está relacionado con la actualización del paquete dnf-plugin-system-upgrade. En la última actualización, este paquete trae un fichero de idiomas con errores.

Para solucionarlo, lo que se puede hacer es lo siguiente:

  • Acceder como root.
  • Ir a la carpeta: /usr/share/locale/es/LC_MESSAGES
  • Renombrar el fichero dnf-plugin-system-upgrade.mo a, por ejemplo, dnf-plugin-system-upgrade.mo.bak para que no lo encuentre.

Y con esto, ya vuelve a funcionar.

edit marcar como ofensivo delete enlace mas

Comments

Perfecto, funciona correctamente. Muchas gracias Albertocsg

Imagen Gravatar de Ferm Ferm ( 2015-09-24 20:03:46 -0600 )edit

¡Funciona!. Muchas gracias.

Imagen Gravatar de davidparracatalan davidparracatalan ( 2015-09-26 09:05:09 -0600 )edit
0

respondido 2015-09-19 17:11:07 -0600

Imagen Gravatar de davidva

Puedes utilizar yum-deprecated para actualizar mientras se resuelve y sale la actualización

1) su
2) yum-deprecated clean metadata
3) yum-deprecated -y update
edit marcar como ofensivo delete enlace mas

Comments

Ya me había pasado este error con yum en fedora 21, la única solución que encontré fue actualizarlo a fedora 22. Saldrá una correción para este problema antes de que salga fedora 23? será un fastidio esperar hasta la nueva versión para solucionar un error.

Gracias por tu ayuda. De hecho por ahora estaré actualizando mediante yumex, pero lo que quería era solucionar el error.

Imagen Gravatar de Ferm Ferm ( 2015-09-19 19:48:47 -0600 )edit
0

respondido 2015-09-19 13:04:15 -0600

Imagen Gravatar de lea89

Hola, quizás esto te ayude: https://yoseft7.wordpress.com/2015/09...

Comenta como te fue. Saludos!

edit marcar como ofensivo delete enlace mas

Comments

SIguiendo el tutorial del link; al probar el comando alternatives --list | grep -i python me arroja este error al leer enlace /usr/bin/javaws: No existe el fichero o el directorio

Imagen Gravatar de Ferm Ferm ( 2015-09-19 19:46:55 -0600 )edit

Herramientas de Preguntas

1 seguidor

Estadisticas

Preguntado: 2015-09-18 10:06:38 -0600

Visto: 2,148 veces

Ultima actualización: Oct 03 '15