32 july update broke microphone (sampling)

After latest July update & restart it appears to be something broken. Assume the kernel.

Working on 31 correctly, working on 32 till July.

NTB: Dell Latitude 5490
Kernel: 5.7.11-200.fc32.x86_64
PulseAudio: pulseaudio 13.99.1-rebootstrapped

The microphone is crackling. Both. integrated or the jack one connected (multiple headphones).

USB one with own DAC are working correctly.

Crackle ffect is stronger when gaining volume of microphone.

Steps done following:


https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting

Nothing helped :frowning:

arecord --list-devices
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

Was playing around with recording samples, chaning PA configuration, restarting etc. Resampling 48kHz vs 44.1Khz freq.

No luck :frowning:

Idk what happened but assume that some update just crew it up.

Is there anybody with the same problem? Or idea what can cause this? Its very annoying for the others. Everyday bussiness calls :frowning:

I would appreciate any usefull idea how to fix this issue, thanks.
If anything is missing, just ping me and I will update it!

Regards,
Zbynek

Hi there!

Well, I had the same problem until this morning when I was able to fix it just replacing the alsa firmware package:

Remove: alsa-firmware
Install: alsa-sof-firmware

Regards,

Xionjames

1 Like

Hi,

unfortunately I already have this done, but it doesnt work.
Is there anything extra? Attached? Kept configuration?

Isnt it kernel related?

[root@koci-ntb ~]# dnf remove alsa-
alsa-lib-1.2.3.2-1.fc32.i686 alsa-plugins-pulseaudio-1.2.2-1.fc32.i686 alsa-sof-firmware-1.5-1.fc32.noarch alsa-utils-1.2.3-4.fc32.x86_64
alsa-lib-1.2.3.2-1.fc32.x86_64 alsa-plugins-pulseaudio-1.2.2-1.fc32.x86_64 alsa-ucm-1.2.3.2-1.fc32.noarch`

Thanks for more info.

Regards,
Zbynek