5.0.9 to 5.0.10 breaks old machine's grub

fedora-30
#1

I upgraded to kernel 5.0.10 on four systems. One very old system (2012) gets an “alloc magic is broken” message in grub. Booting it back into 5.0.9 works. Does anyone know if they cleaned out some legacy drivers in vmlinuz between 5.0.9 and 5.0.10?

#2

This problem seems to be the same as Grub booting problem after upgrading to Fedora 30: "free magic is broken at ..", in which they updated to the latest version of the kernel which solved their issue. Please try upgrading your system to see if it’s fixed.

2 Likes
#3

That was a fast turnaround on the kernel. 5.0.11 solved it. Thanks.

2 Likes