A used repository hasn't been enabled

I installed the Steam client by running (reference):

$ sudo dnf install -y fedora-workstation-repositories
$ sudo dnf install -y steam --enablerepo=rpmfusion-nonfree-steam

The sudo dnf repolist command doesn’t display the added repo:

repo id                        repo name
fedora                         Fedora 32 - x86_64
fedora-cisco-openh264          Fedora 32 openh264 (From Cisco) - x86_64
fedora-modular                 Fedora Modular 32 - x86_64
rpmfusion-free                 RPM Fusion for Fedora 32 - Free
rpmfusion-free-updates         RPM Fusion for Fedora 32 - Free - Updates
updates                        Fedora 32 - x86_64 - Updates
updates-modular                Fedora Modular 32 - x86_64 - Updates

I never wanted to add the non-free repository permanently, only temporarily in order to install Steam. Does this confirm that no rpmfusion-nonfree repo is used on my system?

1 Like

rpmfusion-nonfree is not used on that system.

it would show up as
rpmfusion-nonfree
rpmfusion-nonfree-updates

1 Like

rpmfusion-nonfree is not used on that system.

So it seems. I’d like to know why the repo hasn’t been added and what the commands specifically do.

Enabling the RPM Fusion repositories using command-line utilities

Although, you don’t really need fedora-workstation-repositories to install steam nowadays as it is provided by the rpmfusion-nonfree repository.

See also: Confused about repositories

1 Like

The command you typed doesn’t enable that repo permanently, but only for that transaction. You can use dnf config-manager to permanently enable/disable repositories.

1 Like

dnf docs more specifically dnf command reference are good for reference for this sort of thing.

1 Like