Accessing external e-sata drive via autofs share from a client without /etc/exports

I have a server perfectly working with autofs and an e-sata drive via the UUID:

cat /etc/auto.misc 
esata	-fstype=auto	:UUID="3c508ae3-1db5-4302-86f4-7b7fa1bc8f58"

Here’s a snip from a df:

df -hk
Filesystem                        1K-blocks     Used  Available Use% Mounted on
/dev/sda1                        1441097788    71200 1367753348   1% /misc/esata

Here’s proof the drive appears:

ls -l /misc/esata
total 20
drwx------ 2 root    root  16384 Nov  4 11:33 lost+found
drwxrwxrwx 4 professor staff  4096 Nov  8 10:22 professor

Is there a way to also automount this from another server without using /etc/exports?

Whenever I try a remote mount like this:

mount -t ext4 newserver:/esata /esata
mount: /esata: special device newserver:/esata does not exist.

I’ve tried with -t nfs and other options, same error.

Logs show:

Nov 12 23:12:14 newserver automount[10396]: attempting to mount entry /misc/esata
Nov 12 23:12:14 newserver automount[10396]: >> /usr/sbin/fsck.ext4: No such file or directory while trying to open 150.108.64.154:/esata
Nov 12 23:12:14 newserver automount[10396]: >> Possibly non-existent device?
Nov 12 23:12:14 newserver automount[10396]: >> mount: /misc/esata: special device 150.108.64.154:/esata does not exist.
Nov 12 23:12:14 newserver automount[10396]: mount(ext2): failed to mount 10.10.1.154:/esata (type ext4) on /misc/esata
Nov 12 23:12:14 newserver automount[10396]: failed to mount /misc/esata

I also don’t want to use /etc/fstab as this is an external e-sata drive so I’m using the UUID to automount as the dev/sd# changes after rebooting either the e-sata or the server it’s connected to.

Perhaps I can use /etc/exports and I just don’t have the syntax correct?

AFAIK /etc/exports is for NFS.

google for sshfs, maybe it’s an option

Right so I don’t think I can use a UUID in /etc/exports

nautilus sftp://newserver/misc/esata

Thanks, that’s more of a work around but I can confirm sftp does work. I am really trying to make it so any user that runs ls -l /misc/esata/, the drive/share appears.