Adobe Reader obbligatorio per inviare segnalazione all'AGCOM

Per inviare una denuncia all’AGCOM, bisogna compilare un PDF che sembra essere modificabile solo con Acrobat Reader 9 o superiori. Si chiama modulo D.

Ho provato prima la versione di Acrobat per Android, ma non riesce a aprire il file.
Così mi sono deciso a installare in un container (toolbox) l’ultimo rpm di Acrobat Reader version 9.5.5, seguendo queste istruzioni. (nota che occorre installare anche il pacchetto gdk-pixbuf2-xlib.i686)

Funziona, ma mi chiedo se c’è un modo per farlo funzionare su Evince o altro lettore PDF open source.
O questi lettori non hanno ancora le funzionalità richieste per poter compilare moduli complessi? Sarei curioso di conoscere i dettagli e magari aprire una feature request per Evince, a meno che non esista già. Se provo a aprirlo con Evince, il PDF mostra solo un messaggio di errore:

If this message is not eventually replaced by the proper contents of the document, your PDF
viewer may not be able to display this type of document.

Ciao @fedelibre
Personalmente non ricordo come feci con un modulo INPS. Mi sa che alla fine lo stampai e lo compilai a mano (per poi usare uno scanner ecc.)
Intelligente l’idea di usare toolbox :slight_smile: per installare un software legacy.

Tecnicamente parlando, non ricordo quali software provai (non esiste solo Evince). È passato tanto tempo, ma all’epoca nessun software ebbe molto successo: c’era sempre qualche campo che dava problemi.

Dall’altro lato, più che aprire una feature request per Evince, proverei ad aprire una feaure request con AGID :sweat_smile: Devono smetterla, soprattutto gli enti pubblici (ma non solo, anche le case editrici di libri per la scuola), di ragionare che nel mondo esista solo Windows e di appoggiarsi a tecnologie con limitata interoperabilità.

Ecco ecco. Ricordo che Master PDF Editor apriva il documento PDF coi form da compilare (ma come ho già scritto, alcuni form non funzionavano).
È un prodotto commerciale, con una versione gratuita (come Acrobat dopotutto), e non so comprando una licenza cosa permette di fare in più.

Il sito è https://code-industry.net/masterpdfeditor/ e lo trovi in GNOME software se hai installato Flathub: https://flathub.org/apps/details/net.codeindustry.MasterPDFEditor

Ho provato quel Modulo D, e la maggior parte dei campi funziona… tranne la parte dove c’è da allegare un documento :frowning_face:

Immagino che quel PDF richieda il supporto a javascript, ma Evince non ce l’ha ancora.

Ho provato anche con Okular, installato da Flathub, ma mi appare la finestra:

This PDF file requires a newer version of Adobe Reader. Press OK to download the latest version or see your system administrator.

Dopo averla chiusa mi appare questo avviso:

Questo documento contiene moduli XFA, che attualmente sono non supportati.

Ecco perché non funziona!
Quindi ho trovato l’issue 1031 di Evince in cui il problema viene discusso approfonditamente.

Direi che in questo caso non posso prendermela con AGCOM.

PS (off-topic)
Ho abbandonato l’idea di mandare la segnalazione a AGCOM.
Volevo segnalare il mancato rispetto della delibera sul modem libero, ma ho scoperto qui che è una pratica scorretta di molti operatori: sul sito propongono un’offerta senza modem, poi quando ti richiamano ti dicono che esiste solo l’offerta con modem. Roba da matti.
Non ho voglia di perdere tempo. Purtroppo so che sono battaglie perse.
In compenso nei commenti di quell’articolo ho trovato un nome di un provider mai sentito prima che sembrerebbe corretto. Vedremo…

L’ho provato e anch’io non riesco ad allegarlo.
Forse funziona solo con la versione a pagamento, vedi qui.
Meglio Acrobat Reader allora.
Grazie comunque per la dritta!